MIME type of text/whatever should be handled as text

RESOLVED DUPLICATE of bug 196078

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 196078
15 years ago
15 years ago

People

(Reporter: Ed Avis, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

Because not every app can know about every MIME file type, the types have two
parts separated by a slash.  The first part is a general description such as
'text' and the second part something more specific.  I think the intention is
that if an app doesn't know exactly how to display text/x-obscure-format, it can
at least fall back to displaying it as text.

However, the URL mentioned above serves a MIME type of text/x-python but
Firebird does not display the content as text; instead it prompts about
downloading.  The MIME type indicates a text document so the page should be
displayed as such.

RFC 1341 seems to suggest this behaviour, though it does not mandate it:

>In general, the top-level Content-Type is  used  to  declare
>the  general  type  of  data,  while the subtype specifies a
>specific format for that type of data.  Thus, a Content-Type
>of  "image/xyz" is enough to tell a user agent that the data
>is an image, even if the user agent has no knowledge of  the
>specific  image format "xyz".  Such information can be used,
>for example, to decide whether or not to show a user the raw
>data from an unrecognized subtype -- such an action might be
>reasonable for unrecognized subtypes of text,  but  not  for
>unrecognized  subtypes  of image or audio.

In the particular case of a web browser, it seems reasonable to always present
textual data to the user when possible.  That way the user has a choice of
whether to view the document in the browser window or use 'Save As'.

Reproducible: Always

Steps to Reproduce:
1. View
<http://cvs.sourceforge.net/cgi-bin/viewcvs.cgi/*checkout*/freevo/freevo/helpers/xml_tv_be.py?rev=HEAD&content-type=text/x-python>


Actual Results:  
A dialogue box appeared asking what to do with this file.

Expected Results:  
The page should have been displayed as plain text, IMHO.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 57342 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
there's a bug that fits much better...
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 196078 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.