"Column 'value' cannot be null" trying to upgrade chart data

RESOLVED FIXED in Bugzilla 2.18

Status

()

defect
--
critical
RESOLVED FIXED
16 years ago
7 years ago

People

(Reporter: justdave, Assigned: gerv)

Tracking

2.17.4
Bugzilla 2.18
Bug Flags:
approval +

Details

Attachments

(1 attachment)

I upgraded bugzilla.syndicomm.com to the cvs tip this morning (last upgrade was
a few months ago).  Error message is probably self explanatory:

Checking perl modules ...
Checking for       AppConfig (v1.52)   ok: found v1.52
Checking for             CGI (v2.93)   ok: found v2.98
Checking for    Data::Dumper (any)     ok: found v2.102
Checking for    Date::Format (v2.21)   ok: found v2.22
Checking for             DBI (v1.32)   ok: found v1.32
Checking for      DBD::mysql (v2.1010) ok: found v2.1024
Checking for      File::Spec (v0.82)   ok: found v0.82
Checking for      File::Temp (any)     ok: found v0.12
Checking for        Template (v2.08)   ok: found v2.10
Checking for      Text::Wrap (v2001.0131) ok: found v2001.0929

The following Perl modules are optional:
Checking for              GD (v1.20)   ok: found v1.41
Checking for     Chart::Base (v0.99)   ok: found v2.2
Checking for     XML::Parser (any)     ok: found v2.30
Checking for       GD::Graph (any)     ok: found v1.35
Checking for GD::Text::Align (any)     ok: found v1

Checking user setup ...
Removing existing compiled templates ...
Precompiling templates ...
Checking for    MySQL Server (v3.23.41) ok: found v3.23.56
Checking for        GraphViz (any)     ok: found

Creating table series_categories ...
Creating table series ...
Creating table user_series_map ...
Creating table series_data ...
Migrating old chart data into database ...
[Sun Aug 10 13:16:49 2003] checksetup.pl: DBD::mysql::st execute failed: Column
'value' cannot be null at ./checksetup.pl line 3737.
[Sun Aug 10 13:16:49 2003] checksetup.pl: DBD::mysql::st execute failed: Column
'value' cannot be null at ./checksetup.pl line 3737.
[Sun Aug 10 13:16:49 2003] checksetup.pl: DBD::mysql::st execute failed: Column
'value' cannot be null at ./checksetup.pl line 3737.
(previous line repeated several hundred times).


Needless to say, none of my existing chart data made it to the new chart system.
 What else would you like from me in order to debug?
This is mine.

Gerv
Assignee: zach → gerv
Dave: can I get one of your old chart data files, or is it too late? I think I
probably know what's going on here (the chart data is just 20030101|||||| rather
than 20030101|0|0|0|0..., and so it's interpreting "" as a null value, which
isn't allowed) but it would be good to confirm it.

Note to self: possible fix is "|| 0" on line 3759, where value is inserted into
database.

Gerv
Yep, that's exactly the case.  The first 70 or 80 lines of the file have |||||
for all the resolution positions.
Dave: if I produce a fix for this, are you able to test that it works for you,
or do you not have the setup to do so anymore?

Gerv
Posted patch Patch v.1Splinter Review
This should do the trick.

Gerv
Comment on attachment 130780 [details] [diff] [review]
Patch v.1

deleted my series* tables, applied this patch, and re-ran it.  It appears to
have worked.  Charts still get good data, and no errors in conversion.
Attachment #130780 - Flags: review+
Flags: approval+
Fixed.

Checking in checksetup.pl;
/cvsroot/mozilla/webtools/bugzilla/checksetup.pl,v  <--  checksetup.pl
new revision: 1.246; previous revision: 1.245
done

Gerv
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Target Milestone: --- → Bugzilla 2.18
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.