Closed Bug 215734 Opened 19 years ago Closed 18 years ago

browser.tabs.opentabfor.urlbar set to false sometimes opens urls in location bar's history in tabs

Categories

(Firefox :: Toolbars and Customization, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 232617

People

(Reporter: logan+mozilla-bmo, Assigned: hyatt)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

The browser.tabs.opentabfor.urlbar pref, when set to false, doesn't always keep
urls in the location bar's history from opening in a new tab.

Reproducible: Sometimes

Steps to Reproduce:
1. Set browser.tabs.opentabfor.urlbar to false
2. Build up a list of urls in the location bar.
3. Select URL from the location bar's history.

Actual Results:  
URL opens in tab (sometimes).

Expected Results:  
Nothing in the location bar should cause a tab to be opened.

Some people have said this is consistent for them, but it doesn't happen all the
time for me.

http://forums.mozillazine.org/viewtopic.php?t=18119
Seeing the same behavior on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b)
Gecko/20030817 Mozilla Firebird/0.6.1+ though it seems to open in tabs *all* the
time when I select a location bar entry with the mouse.  (This may just because
I don't notice when it's behaving properly.)  This is with TBE, though open in
tabs from location bar is definitely disabled.  I'll try later without TBE
unless somebody else confirms without TBE beforehand.

Don't see it at all on XP though.  (Mozilla/5.0 (Windows; U; Windows NT 5.1;
en-US; rv:1.5b) Gecko/20030820 Mozilla Firebird/0.6.1+)
WFM 20030907 build on W2K. Logan, do you have TBE installed? Can you retest with
a current nightly build with a fresh profile and without extensions.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030907 Firebird/0.6.1+

Well one thing has changed for me, it does it every time now. :P

I don't have TBE installed, only extention I do have is the useragentswitcher,
which I don't think should cause any problems.
Is this still a problem?
Yep.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

Created a new profile, and the only pref I changed was opentabfor.urlbar. After
restarting firebird, it took a bit of fiddling to happen again. I kept switching
between two sites using the urlbar.
confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I just started seeing this with the latest trunk nightlies of Firebird, starting
with the 20040115, and just saw it again on 20040120.  This is on Windows 9x and XP.
i am seeing this on firefox 0.8 under linux only, windows xp and nt 4 seem to be
fine. opentabfor.urlbar is definitely set to false on these systems, yet it just
seems to ignore it on linux occasionally.
Have not seen any traffic on this bug in 3+ months, however, have been using 0.9
for 2 or 3 weeks now, and have not seen this occur yet.  Is anyone still seeing
this bug in 0.9/0.9.1?
Hm, guess my summary wasn't so good... Bug 232617, filed a few months later,
appears to have become the main bug for this issue (closed as FIXED). I don't
see the problem anymore so I'm gonna resolve this as dupe.

*** This bug has been marked as a duplicate of 232617 ***
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.