Preferences category tree misaligned when scrollbar dissapears

RESOLVED DUPLICATE of bug 212839

Status

()

Core
XUL
--
enhancement
RESOLVED DUPLICATE of bug 212839
15 years ago
10 years ago

People

(Reporter: Bob Firth, Assigned: janv)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030808

When a branch in the prefs category tree is contracted so that the scrollbar is
no longer required, the tree is aligned to the bottom of the pane instead of the
top. 

Reproducible: Always

Steps to Reproduce:
1. go to edit->preferences
2. expand some branches to make the scrollbar appear (e.g. only Composer,
ChatZilla, Advanced)
3. scroll down so that the top of the tree is no longer visible
4. contract one of the branches to make the scrollbar dissapear (e.g. Advanced)
Actual Results:  
The tree which is now small enough to fit in the pane is aligned to the bottom
of the pane, and there are tree fragments filling the space at the top.

Expected Results:  
The tree should be aligned to the top of the pane.
(Reporter)

Comment 1

15 years ago
Created attachment 129586 [details]
screenshot of displaced tree

screenshot of displaced tree (should be aligned to top, without random tree
bitties added on top)
.
Assignee: bugs → varga
Component: Preferences → XP Toolkit/Widgets: Trees
QA Contact: sairuh → shrir

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 212839 ***
Severity: trivial → enhancement
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: XP Toolkit/Widgets: Trees → XUL
QA Contact: shrir → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.