echo the folder name incorrectly when creatd a new profile.

VERIFIED DUPLICATE of bug 200439

Status

VERIFIED DUPLICATE of bug 200439
16 years ago
14 years ago

People

(Reporter: terry.shi, Assigned: jag+mozilla)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830
Build Identifier: 

Echo the folder name incorrectly when creatd a new profile.

Reproducible: Always

Steps to Reproduce:
1../mozilla -ProfileManager or -ProfileWizard.
2. push the button "create profile".
3. input profilename.




if type the following command
./mozilla -ProfileManager or -ProfileWizard

When inputing a new profile name to create a new profile,mozilla echos the
folder name incorretly.
> User-Agent:   Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830
> Build Identifier: 

Are you seriously filing a bug on Mozilla 1.0.1?  If not, what build _are_
youfiling the bug on?

Finally, what exactly are you typing and where to produce the problem?
(Reporter)

Comment 2

16 years ago
My build is mozilla 1.4. 

1../mozilla -P ProfileManager
2.push the button "Create Profile"
3.when I input a new profile name,the actual folder name that is echoed is not
same as the new profile name.

Please try that.

Comment 3

16 years ago
> what exactly are you typing and where to produce the problem?

  You didn't answer bz's question above, yet. What exactly did you type (set
View|Character Coding to UTF-8 before typing Chinese characters or any non-ASCII
characters) and what was the name of a new profile created by Mozilla (that you
reported was different from what you typed)? 

> My build is mozilla 1.4.

  On Solaris or Linux or what else and under what locale? When you filed a bug,
you used Mozilla 1.01 as show in comment #0. There's nothing wrong, but I just
want to make sure that what you reported is actually a 1.4 issue not a 1.01 issue. 

  Besides, can you try it on a recent nightly build see if you still have a
problem? 
(Reporter)

Comment 4

16 years ago
Two days ago I updated my mozilla code from mozilla.org.I am sure that mozilla
Trunk and mozilla1.4 both have this problem.

when I type the profile name with ASCII characters, for example "terry",
the following folder name echos "terr" .I think the length of profile name
string is less than the actual length. 

other examples:
1. type 't' ,echo '';
2. type 'e' ,echo 't';
3. type 'r' ,echo 'te';
4. type 'r' ,echo 'ter';
5. type 'y' ,echo 'terr'

I think it's the problem of code /mozilla/profile/resoures/content/newProfile1_2.js 
                                 /newProfile1_2.xul.

Please notify me if I am wrong.Thanks

Comment 5

16 years ago

*** This bug has been marked as a duplicate of 200439 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 6

16 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.