Access keys don't toggle check boxes which have focus

RESOLVED DUPLICATE of bug 222297

Status

()

--
minor
RESOLVED DUPLICATE of bug 222297
16 years ago
15 years ago

People

(Reporter: jbarros, Assigned: aaronlev)

Tracking

({access})

Trunk
x86
Windows XP
access
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030809 Mozilla Firebird/0.6.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030809 Mozilla Firebird/0.6.1+

When a page has a checkbox with an associated <label> element, pressing the
defined access key while the checkbox has the focus does not toggle the state of
the checkbox.

Reproducible: Always

Steps to Reproduce:
1. Load the testcase in a browser window.
2. Press ALT+T (or equivalent).  Checkbox has the focus and is checked.
3. Without altering the focus, press ALT+T again.
Actual Results:  
Checkbox is not unchecked.

Expected Results:  
Checkbox should be unchecked.

This bug is also present in Mozilla 1.4 (20030624).
(Reporter)

Comment 1

16 years ago
Created attachment 129645 [details]
Testcase
(Assignee)

Comment 2

16 years ago
This could be related to bug 214368.

In that bug, I think the checkbox gets set twice very quickly, so it ends up at
its original state. It all happens so quickly that you don't get to see it.
(Reporter)

Comment 3

16 years ago
I think this may be a different issue, because clicking the label in the
testcase (as opposed to using the accesskey) works as expected.

Updated

16 years ago
Keywords: access

Comment 4

15 years ago

*** This bug has been marked as a duplicate of 222297 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.