collectstats.pl: Use of uninitialized value in pattern match (m//) at Bugzilla/Util.pm line 49.

RESOLVED DUPLICATE of bug 210735

Status

()

Bugzilla
User Accounts
RESOLVED DUPLICATE of bug 210735
14 years ago
5 years ago

People

(Reporter: justdave, Assigned: gerv)

Tracking

Details

Get one of these every night:

Date: Tue, 12 Aug 2003 03:00:04 -0700
From: root@sinclair.syndicomm.com (Cron Daemon)
To: root@sinclair.syndicomm.com
Subject: Cron <root@sinclair> cd /var/www/webapps/bugzilla ;
/var/www/webapps/bugzilla/collectstats.pl
X-Cron-Env: <SHELL=/bin/sh>
X-Cron-Env: <HOME=/root>
X-Cron-Env: <PATH=/usr/bin:/bin>
X-Cron-Env: <LOGNAME=root>

[Tue Aug 12 03:00:03 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:04 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:05 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:05 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:05 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:05 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:05 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:05 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:05 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:05 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:05 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:05 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:05 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:05 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:05 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:05 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:05 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:05 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:05 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:05 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:05 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:05 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:05 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:05 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:05 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:05 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:05 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:05 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:05 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:05 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:05 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:05 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:05 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:05 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:05 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:05 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:05 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:05 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
[Tue Aug 12 03:00:05 2003] collectstats.pl: Use of uninitialized value in
pattern match (m//) at Bugzilla/Util.pm line 49.
Did some debugging here and this actually traces back to User.pm.

trick_taint() called with undefined value at Bugzilla/Util.pm line 49.
        main::die_with_dignity('trick_taint() called with undefined value at
Bugzilla/Util.pm li...') called at Bugzilla/Util.pm line 49
        Bugzilla::Util::trick_taint(undef) called at Bugzilla/User.pm line 71
        Bugzilla::User::_create('Bugzilla::User', 'userid=?', undef) called at
Bugzilla/User.pm line 44
        Bugzilla::User::new('Bugzilla::User', undef) called at ./collectstats.pl
line 458
        main::CollectSeriesData() called at ./collectstats.pl line 85

Which makes this a duplicate of bug 201735

*** This bug has been marked as a duplicate of 201735 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Component: Reporting/Charting → User Accounts
Resolution: --- → DUPLICATE
errrr... let's try that again.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
make that bug 210735

I hate typoes.

*** This bug has been marked as a duplicate of 210735 ***
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.