selected item in Combo / Drop-down list not refreshed correcly after reload. Force reload works

VERIFIED DUPLICATE of bug 46845

Status

SeaMonkey
Composer
--
major
VERIFIED DUPLICATE of bug 46845
14 years ago
12 years ago

People

(Reporter: Jerome Lacoste, Unassigned)

Tracking

1.4 Branch
x86
All

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
I have a web page that is generated by a Servlet. This page contains components
among whic text fields and drop down lists. The items in the drop down list are
selected.
I modify the DB in which the values used for the page are stored using an
external program. I refresh the page using the CTRL+R or refresh button. Mozilla
retrieves a new page from the server, updates some fields (the text fields) but
fails to update correctly the selected items in the drop down list, even thought
the HTML code in the source page shows the correc selected item.
(Reporter)

Comment 1

14 years ago
More information:
- I searched for duplicates using selected, combo and refresh keywords
- I wasn't sure if that problem pertained to layout:View Rendering so I let it
in General.
- the page is generated by a servlet which first makes a query to a DB and then
forward the result to the browser to a JSP. Reloading the page makes the browser
reask for the action page that re-executes the query (thus retrieving thenew
value) and reforward a new content to the browser.
- the problem happens both with Mozilla 1.3 on W2K and mozilla 1.4 on Linux.
- the problem does not happen with IE 6.0
- If I chose Shift-Reload, the browser will correcly update the page. With
reload alone it doesn't work, but the page is correctly redownlaoded as shown by
view source
- the code in the HTML page is as following (a drop-down component inside a cell
of a table)

      <td class="withBorder center" valign="top">
          <input type="hidden" name="FS.0.FT.0.ID" value="252">
          <input type="hidden" name="FS.0.FT.0.orderNo" value="1">
          <select name="FS.0.FT.0.targetID">
            <option value="" > </option>
              <option value="1">1</option>
              <option value="2">2</option>
              <option value="3">3</option>
              <option value="4">4</option>
              <option value="5">5</option>
              <option value="6">6</option>
              <option value="7">7</option>
              <option value="8">8</option>
              <option value="9">9</option>
              <option value="10">10</option>
              <option value="11">11</option>
              <option value="12">12</option>
              <option value="13">13</option>
              <option value="14">14</option>
              <option value="15">15</option>
              <option value="16" selected>16</option>            
          </select>

But the selected item on the screen is the item 4, which was the value used by
the page before the refreshing.
It seems like the refresh onscreen is cut at some point.

If there is anything i can do to help debugging, like to enable specific trace,
do not hesitate to contact me.
Component: Browser-General → Editor: Composer
"refresh" is usually called "reload" in Mozilla (that's what the menuitem says, 
eg).

*** This bug has been marked as a duplicate of 46845 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Comment 3

12 years ago
It seems self evident to me that if the rendering disagrees with the underlying
html, as is the case when the selected option of a select list is not in fact
"selected", this is a gross bug, which makes it impossible to create dynamic web
pages that behave properly and predictably on Mozilla.

--Frank Hanny 
fchanny@lbl.gov
You need to log in before you can comment on or make changes to this bug.