Using DOCTYPE seems to cause layout error for spacer image.

VERIFIED DUPLICATE of bug 22274

Status

()

Core
Layout
VERIFIED DUPLICATE of bug 22274
15 years ago
15 years ago

People

(Reporter: Robin Becker, Unassigned)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US) Netscape6/6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

The two URL's

http://server.reportlab.com/www_reportlab_com/moztest0.html
http://server.reportlab.com/www_reportlab_com/moztest1.html

differ only in that the moztest0.html contains a strict DOCTYPE declaration
ie
$diff moztest0.html moztest1.html
2d1
< <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

but moztest0.html doesn't seem to respect the height/width of the
first row (defined by a spacer image). In moztest1.html (without the DOCTYPE)
things seem to be correct. 

Reproducible: Always

Steps to Reproduce:
1. view http://server.reportlab.com/www_reportlab_com/moztest0.html
2. view http://server.reportlab.com/www_reportlab_com/moztest1.html
3. observe they differ (top row is not 1 pixel high for step 1).
4. compare the sources.
Actual Results:  
The two pages differed.

Expected Results:  
Mozilla should respect the style="height: 1; width:800..." etc in the
same way for bot docs.

*** This bug has been marked as a duplicate of 22274 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
Verified duplicate.

See http://devedge.netscape.com/viewsource/2002/img-table/  for solutions to
this specific problem.

Additionally, you need to specify a unit after the values for 'height' etc.

See http://mozilla.org/docs/web-developer/quirks/ for further info regarding
Quirks/Almost Standards/Full Standards layout mode.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.