Unexpected new window created when I "Click here to remove all expired articles"

VERIFIED DUPLICATE of bug 129574

Status

MailNews Core
Networking
VERIFIED DUPLICATE of bug 129574
15 years ago
10 years ago

People

(Reporter: ISHIKAWA, Chiaki, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624

Newsreader sometimes shows the
header line for "expired article" in the sense
that
 - the subject is shown,
 - but if I try to read the artcile by clicking on it,

the newsreader responds with something like this:

Error!

newsgroup server responded:Bad article number

Perhaps the article has expired

<bh16kj$vru$04$1@news.t-online.com> (53191)

Click here to remove all expired articles  <--- This is a clickable link.

The articles gets expired at the server at regular intervals, and
so local xover database gets out of sync and the
failure of accessing expired article is understandable and
handled by many newsreaders gracefully
including netscape 4.xx.
 
The annoying problem with mozilla is that
when I click on the "Click here to remove
all expired articles",
a NEW news window popos up and it seems that
the resulting subject lines (with the expired ones
removed) are shown there
instead of the original news window.

This is rather annoying.

Netscape 4.xx handles this case 
without creating a new window, and that behavior is
much nicer to work with.



Reproducible: Always

Steps to Reproduce:
1.Trying to access an expired article by
  clicking on its subject line in a news window.
2. The mozilla shows a response message in which
   "Click here to remove all expired articles." link appears.
3. When I click on the link, a new news window is unnecessarily created.


Actual Results:  
A new news window is created, and it is confusing.

Expected Results:  
I would like to see the action (of removing the
expired articles from the subject line display) performed
in the SAME news window where I clieck the
"Click here ..." link.


Mozilla behaves like this from the first time I tried
the 0.x build, say at least a year ago or so.

I am not sure if this is a bug or a feature, but
I believe that the creation of a new window was not intentional.
Maybe the test environment in which the authors responsible for the
code didn't create the situation of "expired articles" often enough
to pose the situation. If these authors learn of the
problem, I think they would think of this as a "bug" rather a feature.

My ISP's server has been flooded by tons of binary posts (it seems) and
they have begun shortening the expiration period left and right
since early last year and I see this problem
more often than before.

I have been using netscape 4.xx for a few years, and
it handles this situation gracefully without creating a
new window.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 129574 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
v.
Status: RESOLVED → VERIFIED
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.