Closed Bug 21624 Opened 20 years ago Closed 20 years ago

[Regression] {css2} Widgets losing :focus attribute not redrawing

Categories

(Core :: XUL, defect, P3)

defect

Tracking

()

VERIFIED DUPLICATE of bug 25258

People

(Reporter: hangas, Assigned: saari)

References

Details

(Keywords: css2)

Setting styles with (and without) :focus used to cause the widget to get redrawn
with the new style when the widget gained and lost focus.  Currently this is
broken such that the widgets only redraw when they gain focus.

This can be demonstrated in the Mail 3 pane view, by clicking on a folder and
then on a mail message.  The folder should switch to a gray selection background
when the focus is lost and passed to the message.  It does not redraw unless the
mouse is moved over the rectangle that contains the folder name.
Blocks: 21151
Summary: [Regression] Widgets losing :focus attribute not redrawing → [Regression] {css2} Widgets losing :focus attribute not redrawing
Status: NEW → ASSIGNED
Target Milestone: M13
Target Milestone: M13 → M15
Keywords: css2
Migrating from {css2} to css2 keyword. The {css1}, {css2}, {css3} and {css-moz}
radars should now be considered deprecated in favour of keywords.
I am *really* sorry about the spam...


*** This bug has been marked as a duplicate of 25258 ***
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
VERIFIED Dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.