Closed Bug 21630 Opened 20 years ago Closed 20 years ago

Chienes IMEs under Windows-2000 not working well

Categories

(Core :: Internationalization, defect, P3)

x86
Windows 2000
defect

Tracking

()

VERIFIED DUPLICATE of bug 29606

People

(Reporter: momoi, Assigned: ftang)

Details

(Whiteboard: [Need help])

** Observed with M11 Rel build under Windows 2000 Beta 3 **

This bug was reported by David Gardiner <David.Gardiner@unisa.edu.au>.
Under Win 2000, at least one of the problem confirmed at this
end is that you cannot commit input in form under Trad Chinese input
methods I tried. You can see the input candidate window but even if you
select one candidate to commit, nothing is shown in form.
David Gardiner reported a problem under Simplified Chinese IMEs on
Win 2000. So apparently this is a general problem with Chinese IMEs.
Target Milestone: M13
Status: NEW → ASSIGNED
Target Milestone: M13 → M14
Move to M14
Windows 2000 is not part of Beta 1 criteria. Move to M17
Makoto-san, can you help ?
Whiteboard: [Need help]
I cannot repro on Windows 2000 Release + Mozilla 2000-01-21-09-M13.

I could input via Simple Chienes IME and Trad Chienes IME.
Momoi san, do you know how to repro?
Change OS to Windows2000
OS: other → Windows 2000
windows 2000 bugs- move to M18
Target Milestone: M14 → M18
Kato-san, so far I looked at only Win 2000 Beta version but there the problems are as follows:

1. With Korean IME -- we get only question marks.
2. With Simplified Chinese IME, I saw wrong characters committed. For example,
   try "chung" and press the space bar, you should be seeing the character for "spring" (haru in
   Japanese) but you see a different character. Try this with other Windows application like
   NotePad or Outlook Express with font and encoding set to Simplified Chinese, you should see
   the problem.

Next we try to set up much more recent version of Win 2000, but since Korean and Simplified Chinese
IMEs seem to be working with other applications, I think we have a problem anyway. 
"2. With Simplified Chinese IME, I saw wrong characters committed. For example,
   try "chung" and press the space bar, you should be seeing the character for "spring" (haru in
   Japanese) but you see a different character. Try this with other Windows application like
   NotePad or Outlook Express with font and encoding set to Simplified Chinese, you should see
   the problem."

I should correct the remark about NotePad and Outlook Express to the following:

"Try this with other Windows application like NotePad or Outlook Express with font and encoding set 
  to Simplified Chinese, you see that they commit the character "spring" correctly."
I could repro via QuanPin and Quick.  But I cannot repro via MS-PinYin98 and  
New Chang Jie...
I have no time to work on this yet. m_kato-san, if you have time, could you 
add a printf("Codepage %d\n", gCurrentKeyboardCP); in nsWindow::OnInputChange()  
after the LangIDToCP() ?
This function will be involk when we switch keyboard layout. I suspect it return  
the wrong value in window 2000
Move it to M16
Target Milestone: M18 → M16
this issue is BUG 29606.
frank, please dup to BUG 29606!
Dup'ing to bug 29606 as suggested by m_kato.  Please update TM on bug 29606,
if appropriate (currently 29606 is M17 and this bug is M16).

*** This bug has been marked as a duplicate of 29606 ***
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Verified as dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.