display bug + duplicate bug info on one screen in the bug

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
16 years ago
7 years ago

People

(Reporter: soloturn99, Unassigned)

Tracking

Details

(Whiteboard: [relations:dupl], URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.1; Linux)
Build Identifier: 

a bug marked as duplicate should include the descriptions of every other 
duplicates on a prominent place. 
 
or, search should give all the duplicate bugs of a result entry too. 
 
it would further prevent adding duplicates, because you get a better picture 
of the bug, as all information + duplicate information is displayed. you don't 
have to grab for duplicates to notice it is already filed. 
 

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Updated

15 years ago
Severity: normal → enhancement

Comment 1

15 years ago
I don't understand the bug description. reporter (solo turn), can you give us an
example?

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 24957 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
I for one don't think this is a dupe, at least not of bug 24957... Bug 24957 is
about buglist.cgi while this bug is about show_bug.cgi.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Updated

14 years ago
QA Contact: mattyt-bugzilla → default-qa
Makes sense to me.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

12 years ago
Assignee: myk → create-and-change
bug 469018 comment 1 suggests display format similar to dependencies
Summary: display bug + duplicate bug info on one screen, and/or search should do this too → display bug + duplicate bug info on one screen in the bug
(In reply to comment #5)
> bug 469018 comment 1 suggests display format similar to dependencies

bug 55436 has a detailed proposal in attachment 449438 [details] how to present information on duplicate bugs in show_bug.cgi. I'm not sure if comment 0 wants to display the full summaries of all duplicates on the main bug, but I'm sure this will not be implemented by default. However, this bug should stay open as a reminder that there should be a way of accessing the complete list of a bug's direct and indirect duplicates including their full summaries. I figure there's basically two ways of doing this:

A) Implement a _show summaries_ toggle link after the list of dupes that bug 469018 seeks to implement. User can click on it to show/hide summaries of the duplicates on the main bug.

B) Add a section for duplicates to our current "dependency tree" page (https://bugzilla.mozilla.org/showdependencytree.cgi):

Bug XXXXX has 5 duplicate bugs (2 direct and 3 indirect duplicates):
    bug yyyyyy the first duplicate bug's summary
    bug zzzzzz the second duplicate bug's summary

C) Of course, we could also have a separate tree only for the duplicates.

I'd think that B) is a reasonable and realistic approach.
Blocks: 55436
Typo fix (In reply to comment #6):

> A) Implement a _show summaries_ toggle link after the list of dupes that
*bug 55436* seeks to implement.

> I'd think that B) is a reasonable and realistic approach.
...and C) looks good, too, if B) is unwanted.
Not sure about A).
Whiteboard: [relations:dupl]

Comment 8

7 years ago
We shouldn't waste room in the bug report with descriptions from other duplicates. With the implementation of bug 55436, you can easily click the "view as buglist" link and get all the information you want from there.
Status: NEW → RESOLVED
Last Resolved: 14 years ago7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.