Closed Bug 216395 Opened 19 years ago Closed 19 years ago

If the VALUE attribute of a form field is not blank, password manager should not fill in/overwrite that value

Categories

(Firefox :: Address Bar, defect)

x86
All
defect
Not set
normal

Tracking

()

VERIFIED FIXED

People

(Reporter: tsigo, Assigned: hewitt)

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

I recently thought I had a bug in my own software, but it turns out that the
form was being created correctly and that a field (username) was being displayed
with my saved information;  Upon viewing the source I found that the VALUE
attribute was correctly filled, but after loading Mozilla just overwrote the
displayed value with the saved value.

My suggestion is to have auto-complete not fill in the field if the source
dictates a value for the field.

Reproducible: Always

Steps to Reproduce:
N/A


Expected Results:  
See details.
Can you attach a test case of this, since it sounds like you have something of
that nature already? It helps us when trying to confirm a bug and helps the devs
when they go to fix it.

Thanks
Best I can do.

This is from my project, EQdkp - http://sf.net/projects/eqdkp/

There's a field called "username" on the login page, where I saved my
information.  Obviously the information is domain-wide, so when I go to the
Manage Users page, and it includes the "username" field, it auto-fills my saved
value rather than the given value.
This test case employs the bugzilla login, so it may be worthwhile logging out
before trying this. The email field should display foo@bar.net but there's a
good chance it will display your email address if you've ever logged in before.
It definitely will the second time you go to this form, which is the "bug".
This may be intended behaviour of the password manager, but I'll confirm it and
let a dev decide. I do find it somewhat odd to produce a login such as my test
case that already has a value for the field...

Forms that aren't logins do not have this bug; the value takes precedence since
the field is not being autofilled by the browser.
Status: UNCONFIRMED → NEW
Ever confirmed: true
This should be fixed now... I just tried out the testcase with my CVS build and
it worked fine (password manager didn't override the value).  Note that you may
need to pick up the fix for bug 217954, which I just checked in, to not _crash_
in this case.
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
Summary: If the VALUE attribute of a form field is not blank, auto complete should not fill in/overwrite that value → If the VALUE attribute of a form field is not blank, password manager should not fill in/overwrite that value
Verified

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030902 Firebird/0.6.1+
Status: RESOLVED → VERIFIED
OS: Windows XP → All
Possible regression caused by fixing this: see bug 220734
You need to log in before you can comment on or make changes to this bug.