crash on exit, [@ nsPrincipal::Certificate::~Certificate ]

RESOLVED DUPLICATE of bug 216234

Status

SeaMonkey
MailNews: Address Book & Contacts
--
critical
RESOLVED DUPLICATE of bug 216234
15 years ago
7 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({crash})

Trunk
x86
Windows 2000
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

crash on exit, might be LDAP over SSL related?

This is in my local tree, with changes for vCard.  (I'll try to verify that's
not part of the problem)

_free_dbg_lk(void * 0xdddddddd, int 1) line 1044 + 48 bytes
_free_dbg(void * 0xdddddddd, int 1) line 1001 + 13 bytes
free(void * 0xdddddddd) line 956 + 11 bytes
PR_Free(void * 0xdddddddd) line 502 + 10 bytes
nsMemoryImpl::Free(nsMemoryImpl * const 0x00267228, void * 0xdddddddd) line 345
+ 10 bytes
nsMemory::Free(void * 0xdddddddd) line 106
nsStrPrivate::Free(nsStr & {...}) line 1008 + 11 bytes
nsStrPrivate::Destroy(nsStr & {...}) line 111 + 9 bytes
nsCString::~nsCString() line 107 + 33 bytes
nsPrincipal::Certificate::~Certificate() + 19 bytes
nsPrincipal::Certificate::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsAutoPtr<nsPrincipal::Certificate>::~nsAutoPtr<nsPrincipal::Certificate>() line
82 + 30 bytes
nsPrincipal::~nsPrincipal() line 117 + 33 bytes
nsPrincipal::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsPrincipal::Release(nsPrincipal * const 0x017338a8) line 92 + 31 bytes
nsCOMPtr<nsIPrincipal>::~nsCOMPtr<nsIPrincipal>() line 475
PrincipalKey::~PrincipalKey() line 106 + 11 bytes
nsBaseHashtableET<PrincipalKey,nsCOMPtr<nsIPrincipal>
>::~nsBaseHashtableET<PrincipalKey,nsCOMPtr<nsIPrincipal> >() line 315 + 26 bytes
nsBaseHashtableET<PrincipalKey,nsCOMPtr<nsIPrincipal> >::`scalar deleting
destructor'(unsigned int 0) + 15 bytes
nsTHashtable<nsBaseHashtableET<PrincipalKey,nsCOMPtr<nsIPrincipal> >
>::s_ClearEntry(PLDHashTable * 0x00f974fc, PLDHashEntryHdr * 0x00f48b88) line 404
PL_DHashTableFinish(PLDHashTable * 0x00f974fc) line 343 + 16 bytes
nsTHashtable<nsBaseHashtableET<PrincipalKey,nsCOMPtr<nsIPrincipal> >
>::~nsTHashtable<nsBaseHashtableET<PrincipalKey,nsCOMPtr<nsIPrincipal> > >()
line 315 + 9 bytes
nsBaseHashtable<PrincipalKey,nsCOMPtr<nsIPrincipal>,nsIPrincipal
*>::~nsBaseHashtable<PrincipalKey,nsCOMPtr<nsIPrincipal>,nsIPrincipal *>() + 15
bytes
nsInterfaceHashtable<PrincipalKey,nsIPrincipal>::~nsInterfaceHashtable<PrincipalKey,nsIPrincipal>()
+ 15 bytes
nsScriptSecurityManager::~nsScriptSecurityManager() line 2652 + 22 bytes
nsScriptSecurityManager::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsScriptSecurityManager::Release(nsScriptSecurityManager * const 0x00f974d0)
line 411 + 215 bytes
nsXPConnect::~nsXPConnect() line 125 + 36 bytes
nsXPConnect::`scalar deleting destructor'() + 15 bytes
nsXPConnect::Release(nsXPConnect * const 0x00f27cb0) line 41 + 148 bytes
nsScriptSecurityManager::Shutdown() line 2660 + 26 bytes
CapsModuleDtor(nsIModule * 0x00f97670) line 431
nsGenericModule::Shutdown() line 368 + 10 bytes
nsGenericModule::~nsGenericModule() line 251
nsGenericModule::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsGenericModule::Release(nsGenericModule * const 0x00f97670) line 253 + 145 bytes
nsDll::Shutdown() line 380 + 18 bytes
nsFreeLibrary(nsDll * 0x00f22640, nsIServiceManager * 0x00000000, int 3) line 280
nsFreeLibraryEnum(nsHashKey * 0x00f361f0, void * 0x00f22640, void * 0x0012fe80)
line 349 + 64 bytes
hashEnumerate(PLDHashTable * 0x0026ff30, PLDHashEntryHdr * 0x00eb68c4, unsigned
int 45, void * 0x0012fe64) line 115 + 26 bytes
PL_DHashTableEnumerate(PLDHashTable * 0x0026ff30, int (PLDHashTable *,
PLDHashEntryHdr *, unsigned int, void *)* 0x1001b6b0 hashEnumerate(PLDHashTable
*, PLDHashEntryHdr *, unsigned int, void *), void * 0x0012fe64) line 619 + 34 bytes
nsHashtable::Enumerate(int (nsHashKey *, void *, void *)* 0x1006a310
nsFreeLibraryEnum(nsHashKey *, void *, void *), void * 0x0012fe80) line 303 + 21
bytes
nsNativeComponentLoader::UnloadAll(nsNativeComponentLoader * const 0x0026fee8,
int 3) line 966
nsComponentManagerImpl::UnloadLibraries(nsIServiceManager * 0x00000000, int 3)
line 3132 + 22 bytes
nsComponentManagerImpl::Shutdown() line 875
NS_ShutdownXPCOM(nsIServiceManager * 0x00000000) line 761 + 11 bytes
NS_ShutdownXPCOM(nsIServiceManager * 0x00000000) line 168 + 13 bytes
GRE_Shutdown() line 297 + 7 bytes
main(int 4, char * * 0x00262638) line 1677 + 5 bytes
mainCRTStartup() line 338 + 17 bytes
KERNEL32! 7c4e87f5()
I tried this out on a trunk build, not changes from me.

checkout start: Sat Aug 16 10:32:39 PDT 2003

so my vCard stuff isn't the cause.

I think this is LDAP over SSL related, but not 100% sure.

but this might be related to bug #206018
Depends on: 206018
not sure what this is, I can get it in other non LDAP over SSL ways.

asa, have you seen any stacks like this?
No longer depends on: 206018
Summary: crash on exit, might be LDAP over SSL (autocomplete) related? → crash on exit, nsPrincipal::Certificate::~Certificate

Comment 3

15 years ago
Seth: Look at bug 215105, comment #5 - shouldn't be both bugs related?
Severity: normal → critical
Keywords: crash
Summary: crash on exit, nsPrincipal::Certificate::~Certificate → crash on exit, [@ nsPrincipal::Certificate::~Certificate ]
Yep, this is a dupe.  Should be fixed in tomorrow's builds.

*** This bug has been marked as a duplicate of 216234 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
Crash Signature: [@ nsPrincipal::Certificate::~Certificate ]
You need to log in before you can comment on or make changes to this bug.