Unable to compile using Sun Studio 8 C Compilter. Build complains about verision.

RESOLVED DUPLICATE of bug 177486

Status

SeaMonkey
Build Config
RESOLVED DUPLICATE of bug 177486
15 years ago
13 years ago

People

(Reporter: Len Smith, Assigned: (default assignee for unassigned bugs. does not receive bugmail))

Tracking

1.4 Branch
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla 1.4 release code.

I am compiling Mozilla 1.4 ( released version ) on Solaris 8, using Sun's Studio
8 compiler suite. The Studio 8 suite replaces the Sun Forte 6.X workshop suite.
During the configure process I receive the following

configure: error: Forte version WS6U2 or higher is required to build. Your compi
ler version is  Sun C 5.5 2003/03/12 .

Doing a cc -V for the old Workshop 6.2 install we have I get:
lendev% /opt/SUNWspro/bin/cc -V
cc: Sun WorkShop 6 update 2 C 5.3 Patch 111679-05 2002/02/07
usage: cc [ options] files.  Use 'cc -flags' for details


Note that 5.3 is the "verison" of the C compiler.

Doing the same for the Studio 8 install I get:
lendev% /opt/bin/cc -V
cc: Sun C 5.5 2003/03/12
usage: cc [ options] files.  Use 'cc -flags' for details

The version is 5.5.

So it looks like the configure script is keying in on the 6, of the
Workshop/Forte version and not the C compiler version.



Reproducible: Always

Steps to Reproduce:
1.Run configure and specify the Studio 8 C compiler
2.
3.

Actual Results:  
Configure goes through and then generate the error:
configure: error: Forte version WS6U2 or higher is required to build. Your compi
ler version is  Sun C 5.5 2003/03/12 .

Expected Results:  
Expected result would have been to go on through and accepted the Sun Studio 8 C
compiler.
(Reporter)

Updated

15 years ago
OS: other → Solaris
Hardware: Other → Sun
(Reporter)

Updated

15 years ago
Version: Trunk → 1.4 Branch

Comment 1

15 years ago
This was fixed after mozilla 1.4 was released.  You need to apply the patch from
bug 177486.


*** This bug has been marked as a duplicate of 177486 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.