EasyWeb / TD CanadaTrust banking crashes / terminates Mozilla [@ ntdll.dll ][@ JS_HashTableAdd]

VERIFIED WORKSFORME

Status

()

--
critical
VERIFIED WORKSFORME
15 years ago
15 years ago

People

(Reporter: jasonb, Assigned: rogerl)

Tracking

({crash, ecommerce})

Trunk
x86
Windows XP
crash, ecommerce
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030819
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030819

When going to the above URL Mozilla simply pauses and the exits - with no
messages of any kind.

(I would give a Talkback number except that my install of the 8/19-04 build
under XP ended up being "incomplete" in that, even though I selected that
component, it wasn't installed.  When trying to install it again via the SEA
install I'm (again) running into a recent problem of XPIs being corrupt or missing.)

I first noticed this last week, but wanted to wait until I was running an up to
date build before reporting it.  I don't know what the cause is, so am leaving
this under "General" for now.

Reproducible: Always

Steps to Reproduce:
1. Go to the URL.

Actual Results:  
Browser terminates without warning.

Expected Results:  
It should have loaded the online banking login page.
(Reporter)

Updated

15 years ago
Keywords: crash, ecommerce

Comment 1

15 years ago
wfm 2003081904 on Win2k, I can load the page completely without crashing (didn't
try logging in as I don't own an account).
(Reporter)

Comment 2

15 years ago
Hmm.  I just tried the ZIP version of today's 8/19-04 build and it didn't crash
either.

So - why would the installer version be any different?  Both use the same
profile, so it can't be anything there.  The only thing that might be a variable
would be my /plugins directory.  I'll try wiping everything out in the Program
directory and see what happens.

Comment 3

15 years ago
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5b) Gecko/20030818
even tried to login with 11111111 as account and password and got to another
page asking me to enter the correct data.
I had the problem with missing talkback with 
Bug 216348 Talkback is missing from windows full installer builds Aug13th, 15th
also couldn´t install talkback.xpi, but mozilla-win32-talkback.zip from the same
day was working fine including talkback.
(Reporter)

Comment 4

15 years ago
Right - this is messed up.

I renamed my /plugins directory and went to the site.  No crash.  I renamed it
back.  The first time I went there it worked fine, on subsequent attempts (5/5)
I got a crash.

I then moved "npdrmv2.dll" out of the /plugins directory and tried again.  It
worked just fine on 5 different occasions.  (Restarting Mozilla each time.)  I
then moved the file back into the /plugins directory - and it hasn't crashed
since.  (I tried going there 10 times and it worked fine each time.)

So I can no longer replicate this problem at present.  I don't have a clue
what's going on here but it looks like I'm forced to close this as WORKSFORME.

Feel free to reopen if anybody else experiences this, can generate Talkback
data, and/or can consistently replicate the problem.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

15 years ago
No, I spoke too soon.  (Sorry for the resulting Spam of status changes here.)

While it certainly does appear to be "random", if I load the site and it doesn't
crash, if I then keep hitting reload over and over, eventually it *will* crash.
 (Although the number of times I need to do this seems totally flexible.)

It does this whether or not I use my regular stub installer build OR the ZIP
version.  (So it's not a question of anything in /plugins or any other file in
the Program directory.)  Additionally, it does this regardless of whether I use
my existing profile or a new, blank one created for testing purposes.

I tried this with Firebird 8/16 and was (Finally!) able to generate a Talkback
ID (since Firebird also crashes when going there):

TB22879267X

It's definitely a 32-bit Windows exception.

(I should have thought of using Firebird earlier, which has Talkback built in.)
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Whiteboard: Talkback ID.

Comment 6

15 years ago
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5b) Gecko/20030819
BuildID 2003081904
Page loaded and didn´t crash, I didn´t retest if I could login with some dummy
password.

I couldn´t install mozilla-win32-installer-sea.exe from folder latest-trunk,
it gave me an errormessage about corrupt xpcom.xpi.
But now I´ve got a younger version of that file from folder 2003-08-19-04-trunk/ 
There had been a similar event before, but please, don´t file a bug.
Bug 216164	Once again corrupted XPCOM.XPI in mozilla-win32-installer-sea.exe on
14th August 2003

Updated

15 years ago
Keywords: stackwanted
(Reporter)

Comment 7

15 years ago
And Talkback ID from a working ZIP Mozilla build is TB22880750Z.

Updated

15 years ago
Whiteboard: Talkback ID. → TB22879267X, TB22880750Z

Comment 8

15 years ago
Tried reloading to produce a crash, without success.
Then repeatedly switched language quickly, and in less thab a minute I got a
blank  window, staying blank at reload. I reopened the website in another tab,
and could reproduce: less thab I minute blank again, but with another URL.
Then opened third tab, ok.

https://easyweb.tdcanadatrust.com/
https://banquenet.tdcanadatrust.com/

Seems to be 8 switches, then a white window. Reload works, but doesn´t display,
Back instantly shows the previous screen.
BTW, BuildID 2003081904 didn´t install talkback.exe
Whiteboard: TB22879267X, TB22880750Z → Talkback ID.

Comment 9

15 years ago
Sorry that I removed Talkback IDs by way of Midair collision.
TB22879267X, TB22880750Z
Trying to readd to Status Whiteboard
Whiteboard: Talkback ID. → TB22879267X, TB22880750Z
(Reporter)

Comment 10

15 years ago
> BTW, BuildID 2003081904 didn´t install talkback.exe

Yes, despite selecting it.  It seems to only be available in the ZIP.

> Tried reloading to produce a crash, without success.

It may need to be a force shift-reload (which is what I've been doing).

Comment 11

15 years ago
TB22880750Z, TB22880750Z -> blank stacktraces

Olivier: could you get some more info from debug build?
Summary: EasyWeb / TD CanadaTrust banking crashes / terminates Mozilla. → EasyWeb / TD CanadaTrust banking crashes / terminates Mozilla [@ ntdll.dll ]
Whiteboard: TB22879267X, TB22880750Z

Comment 12

15 years ago
Adam: couldn't get my debug Linux build 20030730 to crash, no warning or
assertion whatsoever in console.
(Reporter)

Comment 13

15 years ago
Is there anything I can do to help debug this further?  (Since my system, so
far, seems to be the only one that's actually crashing.)  Is there some kind of
logging I could turn on that might help the situation?
(Reporter)

Comment 14

15 years ago
The problem persists in the 9/2-04 Win32 build of Mozilla.

Either going to the login page, or clicking on ANY of the links once logged in
and starting to do online banking.  At some (random) point the browser will just
exit.  It's random because the same link will often work when I start the
browser again and go back to it - but, sooner or later, using any of the links
on the https: site will crash Mozilla.

> couldn't get my debug Linux build 20030730 to crash

Is there such a thing as a debug Win32 build that I could somehow install that
would provide more feedback?

Comment 15

15 years ago
I don´t crash on the login site, but I´ve got no account to login, and there
isn´t a demo page. Via Help -> Login Help -> Other -> Security&Browsers -> What
browsers work with EasyWeb?  I got to the page below, see link.
I would recommend testing with Netscape 7.x, since they tell Netscape 4.05 and
higher is supported, beta browsers not. Seems that Opera, Konqueror, Mozilla,
Safari are beta-browsers.
Do you crash at the login page before submitting any login data, just entering
the data, but not submitting?

Supported browsers:

https://www.tdcanadatrust.com/easyweb5/help/banking/acc00073.htm

What browsers work with EasyWeb?

To login to the EasyWeb you will require a web browser with 128-bit encryption.
 We have optimized our service to work with browsers that the majority of our
customers use.  They are as follows: 

    * Microsoft Internet Explorer (IE) version 4.01 Service Pack 2 (SP2) or higher
    * Netscape Navigator version 4.06 or higher 

      *Beta browsers are not supported

Operating System:
You must have a 32-bit operating system - Windows 95, 98, 2000,NT, ME; MAC 7.5
and higher; Linux 2.2

Note: Windows 2000 operates with Netscape 4.7 or higher browsers and Internet
Explorer 5.01 or higher
(Reporter)

Comment 16

15 years ago
> Do you crash at the login page before submitting any login data

Just loading the URL is enough.  (Or doing a Shift-reload enough times.)

I'm getting really frustrated with this one - not least of all because nobody
seems to know what logging options I can turn on in my browser to try to capture
more useful data about the crash I'm seeing.  (Apparently neither set of
talkback data I submitted contained any stacktrace information.)

Comment 18

15 years ago
-> JS?
Assignee: general → rogerl
Status: REOPENED → NEW
Component: Browser-General → JavaScript Engine
Keywords: stackwanted
QA Contact: general → pschwartau
Summary: EasyWeb / TD CanadaTrust banking crashes / terminates Mozilla [@ ntdll.dll ] → EasyWeb / TD CanadaTrust banking crashes / terminates Mozilla [@ ntdll.dll ][@ JS_HashTableAdd]
(Reporter)

Comment 19

15 years ago
I no longer seem able to reproduce this with the 10/13-04 Win32 build. 
Resolving as WORKSFORME for now.  (I'll reopen it if I encounter this in the
future.)
Status: NEW → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WORKSFORME

Comment 20

15 years ago
Jason: thanks. Marking Verified for now -
Status: RESOLVED → VERIFIED
Crash Signature: [@ ntdll.dll ] [@ JS_HashTableAdd]
You need to log in before you can comment on or make changes to this bug.