message header pane repaint problem with expand and collapse

RESOLVED DUPLICATE of bug 167468

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 167468
15 years ago
14 years ago

People

(Reporter: Siva Dirisala, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

When the message header pane is collapsed, it doesn't collapse it properly and
show the message body below if the message header is already big in expanded
state and the message body is not showing up.

Reproducible: Always

Steps to Reproduce:
1. Adjust the split bar so that the message list is large.
2. Open a message by clicking it (not in a separate window)
3. Expand the message header (subject, from, to etc) and make sure that the 
   split bar in step 1 is adjusted such that the message header pane occupies 
   the rest of the window that you can't see the message body.
4. Now collapse the message header pane. You see that it is back in collapse
   state and see the "Subject" at the top. However, you will notice that the
   original expanded view still exists instead of replacing it with the message
   body.




Actual Results:  
You see that it is back in collapse
   state and see the "Subject" at the top. However, you will notice that the
   original expanded view still exists instead of replacing it with the message
   body.


Expected Results:  
You see that it is back in collapse
   state and see the "Subject" at the top. However, you will notice that the
   original expanded view still exists instead of replacing it with the message
   body.


When this happens, readjusting the split bar by moving it repaints the message
body. Infact, any other window event that causes the mail window to repaint 
results in showing the message body (Examle, moving another window on top of
the mail window and removing it or minimizing and maximizing the mail window).

Comment 1

15 years ago
Reporter, note that the duplicate bug has been marked Fixed; if you get a 
current (nightly) 1.5b build, you'll see this problem has gone away.

*** This bug has been marked as a duplicate of 167468 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.