download complete web page to 'foo' not 'foo.html' creates directory '_files' instead of 'foo_files'

RESOLVED DUPLICATE of bug 184108

Status

SeaMonkey
Download & File Handling
RESOLVED DUPLICATE of bug 184108
15 years ago
10 years ago

People

(Reporter: ejhuff, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

First download a web page with "show all files (*)".
Then re-download it with "web page complete" using the same name.
First time it correctly creates file "foo" and not "foo_files/".
Second time it overwrites "foo" and makes "_files/" instead of "foo_files/".


Reproducible: Always

Steps to Reproduce:
1.First download a web page with "show all files (*)".
2.Then re-download it with "web page complete" using the same name.
3.

Actual Results:  
Second time it overwrites "foo" and makes "_files/" instead of "foo_files/".


Expected Results:  
It should overwrite "foo" and create directory "foo_files/".
(Reporter)

Comment 1

15 years ago
It was 'foo.html' and '_files/' not 'foo' and '_files/'.
(Reporter)

Comment 2

15 years ago
Sorry, it's not that 'foo' exists, it's that foo does NOT have
extension .html.

(Reporter)

Comment 3

15 years ago
Changed summary.  If I then download a different page to 'bar' (not 'bar.html'),
then the files in '_files/' are all deleted and the files for the new page
are added, without comment.

If I download to 'foo.html' it creates 'foo.html' and 'foo_files/'.
If I then delete foo.html and redownload, it does not re-create
the directory, but replaces the files without comment.

Hmm, what happens if 'foo_files/' is a symlink to an existing directory
full of good stuff?

Summary: download complete web page over existing file 'foo' creates directory '_files' not 'foo_files' → download complete web page to 'foo' not 'foo.html' creates directory '_files' instead of 'foo_files'

Comment 4

15 years ago
I searched bugzilla for _files and got into this bug ;)
but this is related somehow ;)

this bug is insane.  look!

when I open http://www.mozilla.org/ and select "save as",
then save it as the default mozilla.org.html, mozilla tries to fetch
these files from www.mozilla.org:
[from tail -f squid/access.log]

1066436584.083   1527 127.0.0.1 TCP_MISS/404 591 GET
http://www.mozilla.org/mozilla.org_files/downloadIconMozilla.gif -
DIRECT/207.126.111.202 text/html
1066436584.154   1598 127.0.0.1 TCP_MISS/404 578 GET
http://www.mozilla.org/mozilla.org_files/header.gif - DIRECT/207.126.111.202
text/html
1066436584.219   1439 127.0.0.1 TCP_MISS/404 592 GET
http://www.mozilla.org/mozilla.org_files/downloadIconFirebird.gif -
DIRECT/207.126.111.202 text/html
1066436584.281   1502 127.0.0.1 TCP_MISS/404 595 GET
http://www.mozilla.org/mozilla.org_files/downloadIconThunderbird.gif -
DIRECT/207.126.111.202 text/html

$ wget -qO- http://www.mozilla.org/ | grep _files
$

and I have mozilla-1.4.1.

Comment 5

15 years ago
also mozilla-1.6 has the same bug.
1074448206.384    564 127.0.0.1 TCP_MISS/404 578 GET
http://www.mozilla.org/mozilla.org_files/ico-fb.gif
6utgocfy001@sneakemail.com: that is a totally different bug, please file a new one.

*** This bug has been marked as a duplicate of 184108 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.