applet loses focus after an other frame did a automated refresh with <meta> tag

RESOLVED WORKSFORME

Status

Core Graveyard
Java: OJI
--
minor
RESOLVED WORKSFORME
15 years ago
8 years ago

People

(Reporter: Michael Eberlein, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: bugday0420, URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; de-AT; rv:1.5a) Gecko/20030718
Build Identifier: Mozilla/5.0 (Windows; U; Win98; de-AT; rv:1.5a) Gecko/20030718

Simple applet with just an text field. If you focus the field and then while you
write some message, the applet looses the focus every time an other frame does
an meta refresh. Other browsers don't act like this. Maybe it is not realy a bug
but it is very pesky and on the other hand I don't want to use an other browser.

Reproducible: Always

Steps to Reproduce:
1.Log in (german) chatroom with some testing nickname (Button "Loslegen").
2.Klick link next to standard input field on the bottom "Java Eingabezeile ..."
3.Write somethin in text field and wait for right frame to refresh.

Actual Results:  
the applet does no longer has focus

Expected Results:  
like other browsers, a refresh made by <meta> tag does not set focus on
refreshed frame

i used mozilla 1.4 and 1.5 but both did the same

Comment 1

15 years ago
Reassigning to Asa, who's not the ultimate right owner but will have a better
idea of who would br

mitchell
Assignee: mitchell → asa

Comment 2

15 years ago
way wrong component
Assignee: asa → general
Component: Miscellaneous → Browser-General
Product: mozilla.org → Browser
QA Contact: mitchell → general
Version: other → Trunk

Comment 3

14 years ago
Mozilla also takes focus from other windows applications. (Using Windows XP and
Mozilla 1.6)

If in MS Word typing and have Mozilla Browser minimized in TaskBar when the page
Mozilla is on refreshes Word loses focus, this is very annoying when the page in
question had a meta refresh time of 30 seconds.

Comment 4

14 years ago
Multiplatform. Please change platform field.

`http-equiv refresh` bug:

related bugs:

53948
66900

Comment 5

14 years ago
it happens to me also, so it's not just a window 98 bug (i have xp)
Product: Browser → Seamonkey

Updated

14 years ago
OS: Windows 98 → Windows XP
Summary: applet looses focus after an other frame did a automated refresh with <meta> tag → applet loses focus after an other frame did a automated refresh with <meta> tag

Comment 6

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED
Moving to Core::Java:OJI (but is that the right component?) and resolving WFM. Feel free to reopen with comment & steps-to-rep if seen in Sm 2.0.4 or later, Fx 3.5.9 or later.
Assignee: general → nobody
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Component: General → Java: OJI
Product: SeaMonkey → Core
QA Contact: general → java.oji
Resolution: --- → WORKSFORME
Whiteboard: bugday0420
Version: Trunk → unspecified

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.