Closed Bug 217116 Opened 17 years ago Closed 17 years ago

don't force use of absolute file names: use $PATH

Categories

(Core Graveyard :: File Handling, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 56662

People

(Reporter: jwz, Assigned: law)

Details

It's lame that the "What should mozilla do with this file" dialog doesn't let me
just type "xine" into the "Open it with" field.  Instead, it makes me have to
figure out whether that is "/usr/bin/xine" or "/usr/local/bin/xine" or
"/usr/X11R6/bin/xine".

Mozilla should let me enter just the *name* of the program, and only complain if
that program does not exist somewhere on $PATH.


Mozilla 1.4
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701
setting it from the preference dialog works... it sets the pref blindly.  When
the pref is actually used,
nsExternalHelperAppService::FillContentHandlerProperties calls
GetFileTokenForPath, which looks through the path.

the helperAppDialog sets preferredApplicationHandler directly without looking at
the path.  
See bug 56662 and also bug 82860 

*** This bug has been marked as a duplicate of 56662 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.