news could not handle a group with the & sign.

VERIFIED DUPLICATE of bug 210089

Status

MailNews Core
Networking: NNTP
--
critical
VERIFIED DUPLICATE of bug 210089
15 years ago
9 years ago

People

(Reporter: Cheng Yuk Pong, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030822 Mozilla Firebird/0.6.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030822 Mozilla Firebird/0.6.1+

If a groupname contain a & sign.
Thunderbird denied to send message to it.
If you read any message on that group, it simpily crash.

Reproducible: Always

Steps to Reproduce:
1. open news://news.hkfanzine.net/comp.BSD&DBMS  (this is a chinese group.. but
this doesn't matter.)
2. post a new article 
3. it say no valid group "comp.BSD&DBMS"  

----
alternative:

1. open news://news.hkfanzine.net/comp.BSD&DBMS
2. try to read any article on it.
3. see it crash.



I don't sure if the NNTP spec allow the & sign in the groupname.. 
But at least, it should never crash.

It have no problem fetching the header.
When it try to fetch the body, it crash..

i have tried thunderbird 0.1 (20030723) and 20030813 ..
This one is very easy to find, please search before you file a bug - thanks


*** This bug has been marked as a duplicate of 210089 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Verified dup
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.