"Preferences..." opens Mozilla-style prefs window when no browser windows are open

RESOLVED DUPLICATE of bug 204418

Status

()

Firefox
Menus
RESOLVED DUPLICATE of bug 204418
15 years ago
12 years ago

People

(Reporter: Adam Backstrom, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

When all browser windows are closed, "Preferences..." under the "Mozilla
Firebird" menu opens the traditional Mozilla- and Netscape-style prefs window
instead of the Firebird-style prefs window.

This is somewhat related to #216494, "Preferences dialog should not be modal,"
in that when there is no browser window open, there is no window available for
the prefs sheet to open inside.

Reproducible: Always

Steps to Reproduce:
1. Close all browser windows
2. Select "Preferences..." from the "Mozilla Firebird" menu




If this is a dupe, I will shoot myself.

Comment 1

15 years ago
Now why would you say a thing like that? You know as soon as you spit those
words out someone like me will come out and dupe it.

This is a dupe of bug 204418.. the first half was to make the long/old mozilla
menu not pop up when theres no windows - which has already been checked in &
FIXED. The Prefs option from this menu now correctly opens the FB prefs. Just
gonna have to wait for a new build or check for a build on the mozillazine forums.

*** This bug has been marked as a duplicate of 204418 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
QA Contact: bugzilla → menus
You need to log in before you can comment on or make changes to this bug.