The frame inside is windows character set. The outside page is Unicode. The Frame is garbage.

NEW
Unassigned

Status

()

15 years ago
9 years ago

People

(Reporter: stephanjunk, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(7 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030827
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030827

The frame should show the correct encoding for the characters.

Reproducible: Always

Steps to Reproduce:
Surf to the page.

Actual Results:  
Garbage ion frame

Expected Results:  
Shown the Western European encoding like IE.

Comment 1

15 years ago
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5b) Gecko/20030827
What are your settings in View->Charactercoding->Autodetect 
and View->Charactercoding->Customize...   Active Character Codings?

Comment 2

15 years ago
Now I see the error: 
it is working on first load, or after you have cleared the cache.
On reload the inner frame is garbled.
PageInfo tells me: text/html, QuirksMode, Disk Cache, UTF-16LE
Tested with two fresh created profiles.
Component: Browser-General → Layout: Fonts and Text

Comment 3

15 years ago
Created attachment 130482 [details]
home.htm

Attachment home.htm is detected as UTF-16LE:
I´m quoting start and ending of the file, the first and the last line here are
written as UTF-16 in the file, i.e. spaces I type are 0x00 in the file,
the other lines are mostly ASCII, only a few characters are UTF-16

< h t m l > < h e a d > < / h e a d > < b o d y ><HTML> 	
<HEAD>
<TITLE>home</TITLE>
</HEAD>


<BODY BGCOLOR="#000066">
<style>
<!--
BOD
 Y{
scrollbar-face-color:#000066;
scrollbar-arrow-color:#FFFFFF;
scrollbar-track-color:#000055;
scrollbar-shadow-color:#FFFFFF;
scrollbar-hi
 ghlight-color:#000066;
scrollbar-3dlight-color:#FFFFFF;
scrollbar-darkshadow-Color:#FFFFFF;
}
-->
</style>
<FONT FACE="verdana, helvetica

 sans-serif" COLOR="FFFFFF">


<center>

................. don´t want to type the whole file .....

</FONT>
</center>



</BODY>
</HTML>




< / b o d y > < / h t m l >

Comment 4

15 years ago
Marking invalid, as there is a nearly correct ( besides a few UTF-16 chars )
ISO-8859-1 HTML file wrapped into the body of an UTF-16LE file.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 5

15 years ago
Created attachment 130485 [details]
home.htm - without UTF-16LE wrapper

I deleted the UTF16-LE head and body tags, and left the rest unchanged.
The space in 'h ome' site and 'b and' activities is a CR LF SPC CR LF sequence
in the source code.

Comment 6

15 years ago
Created attachment 130486 [details]
home.htm - the original file, as txt/html

Comment 7

15 years ago
Created attachment 130490 [details]
HTTP Header saved from LiveHTTPHeaders extension

I attached the HTTP header, as seen with an extension from
http://livehttpheaders.mozdev.org/

Can thiis be a server problem, two servers in a row?

Comment 8

15 years ago
The image of the page hit counter is a .png file, but gets served as text/html,
according to the memory cache info. There is also an invalid closing script tag.

<a href=http://www.bishopmcdevitt.org/mcdband target=_top>
<img border=0 alt=""
src="http://gmsgms.freelogs.com/counter/index.php?u=gmsgms&s=bluepl"
ALIGN="middle" BORDER=0 HSPACE=4 VSPACE=2></a> 

</script>  

Attaching Memory Cache Entry, Pagecounter as HTML, and Pagecounter as PNG.
Link to pagecounter: http://gmsgms.freelogs.com/counter/index.php?u=gmsgms&s=bluepl

this is clearly invalid html, so could be an Tech Evangelism bug.

I reopen this bug, because Mozilla shouldn´t change it´s character set on a
binary file inside an image tag, served as text/html.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 9

15 years ago
Created attachment 130595 [details]
Cache entry information

Comment 10

15 years ago
Created attachment 130596 [details]
testcounter served as png

Comment 11

15 years ago
Created attachment 130597 [details]
pagecounter served as htm

I also had a crash when trying to view frame source, Talkback ID TB23170439W

Is this bug seen on windows only?

Updated

15 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 12

15 years ago
Hermann: Filled bug 217967 for your crash.

Assignee: general → nobody
QA Contact: general → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.