After using Mozilla for a little while, display corruption begins to occur.

RESOLVED DUPLICATE of bug 204374

Status

defect
--
major
RESOLVED DUPLICATE of bug 204374
16 years ago
15 years ago

People

(Reporter: ben, Unassigned)

Tracking

1.4 Branch
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030624

When I have been using Mozilla for a little while, and actively loading pages,
display corruption begins to occur.  The corruption only affects the mozilla
window, and appears to be a case of redraw requests being ignored.   

If I minimize and then restore the Mozilla window, the window comes up mostly
gray, with a few of the elements drawn in as they are supposed to be.  Bringing
up another window (of a different application) and dragging it around the screen
will cause Mozilla to redraw the uncovered areas without problems.  Also,
hovering the mouse over active Mozilla controls (such as the forward/back
browser buttons) will cause those controls to redraw correctly.  Switching tabs
will not redraw correctly by itself.  Sometimes the correct page is rendered,
and sometimes no rendering occurs (leaving the previous page appearing in the
browser, but with the incorrect tab highlighted).   

I have never observed this problem in a non-tabbed session, but I almost never
have an untabbed browser window open.  This problem has never occurred until I
upgraded to 1.4 from what I had before (either 1.2 or 1.3).  When I usually
observe it is when I have run a search on Google, and am opening search results
in separate tabs.  I have the search results sidebar turned off, and tabs set to
load in the background.  I typically have three to five pages loading
simultaneously in the background when the problem occurs.   

When I upgraded to 1.4, I also began using the e-mail client.  I don't know that
this information is relevant, but it could be.  I am not sure if I have ever
experienced the corruption in a session where I never opened the e-mail client.
 The e-mail accounts are set not to check for new messages except on startup or
manual request.

Reproducible: Sometimes

Steps to Reproduce:
1. Go to Google and run a search
2. Bring up a few of the results in tabs (loading in background)
3. Browse around for about ten minutes, closing some tabs and opening others.

Actual Results:  
Sometimes the display corruption begins.

Expected Results:  
Work normally.

I have only run Mozilla with the Modern theme that is included in the download
package.
(Reporter)

Comment 1

16 years ago

Additional note: When the problem occurs, it affects all Mozilla application
windows, although I have never observed the download manager displaying in a 
corrupted manner.  One time I closed everything except the download manager,
then opened a new browser window.  The new window immediately exhibited the problem.

(Reporter)

Updated

16 years ago
Version: Trunk → 1.4 Branch

Comment 2

16 years ago
what video card and driver version do you run ? If Nvidia, ATI, can you upgrade
to latest drivers and report if it works any better ? Otherwise, you might be
seeing bug 204374.
dupe..

*** This bug has been marked as a duplicate of 204374 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.