debug query doesn't display in "please wait" serverpush page

RESOLVED FIXED in Bugzilla 2.18

Status

()

defect
--
minor
RESOLVED FIXED
16 years ago
7 years ago

People

(Reporter: myk, Assigned: myk)

Tracking

unspecified
Bugzilla 2.18
Bug Flags:
approval +

Details

Attachments

(1 attachment)

Adding debug=1 to a buglist.cgi URL causes the query to be displayed at the top
of the bug list, but it doesn't appear in the "Please wait..." intermediate page
that gets displayed while the query is being executed, even though the template
for that page contains code to display the query.

The problem is that the query and the debug flag don't get added to the vars
array until after the intermediate page has already been displayed.  The fix is
simply to add them to the array beforehand.

Note also bug 150105, which this isn't a duplicate of.
Attachment #130476 - Flags: review?(justdave)
Comment on attachment 130476 [details] [diff] [review]
patch v1: fixes problem

works for me.  This is better in case the query times out. :)
Attachment #130476 - Flags: review?(justdave) → review+
Checking in buglist.cgi;
/cvsroot/mozilla/webtools/bugzilla/buglist.cgi,v  <--  buglist.cgi
new revision: 1.233; previous revision: 1.232
done
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Target Milestone: --- → Bugzilla 2.18
Assignee: justdave → myk
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.