Mozilla crashes with no talkback downloading from this link.

RESOLVED FIXED

Status

SeaMonkey
Download & File Handling
--
critical
RESOLVED FIXED
15 years ago
14 years ago

People

(Reporter: Christopher Ebert, Assigned: Blake Ross)

Tracking

({crash})

Trunk
PowerPC
Mac OS X
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5a) Gecko/20030721
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5a) Gecko/20030721

When I click on the link given (on the jEdit download page) the browser crashes.
I'm running OS X 10.1 on a Lombard Powerbook (if that makes any difference?).

Exits saying it hasn't hurt anything else. Tried several times, always the same
result.


Reproducible: Always

Steps to Reproduce:
1. Go to jEdit.org
2. Select 'download'
3. Select latest version
4. Select a download source -- I was using Arizona.
5. Scratch head when browser crashes. Wonder if it will happen again.
6. Repeat :).

Actual Results:  
Browser crashed with dialog box saying it hadn't hurt anything else.

Expected Results:  
Um, downloaded my nice file? Or at least let me down a little more gracefully....

Sorry, no MacsBug :(

Comment 1

15 years ago
This might be a dupe of bug 213639. Bug 216497 is also similar, but that bug is
probably a dupe of bug 213639. All reports comes from users running Mozilla on
Mac OS 10.1.x. Christopher, could you please attach the crash report entry
associated with this
crash? (~/Library/Logs/CrashReporter/Mozilla.crash.log). Should be at the bottom
of the file. The entries are separated by "*******". If you don't get any crash
report, do you see anything in the console when you crash?

Also, does Mozilla just crash on the reported link, or can you reproduce the
problem on more download links?

Do you crash if you use the contextual menu (Save link target as...)?

Finally, can you reproduce the problem with a more recent build?

Updated

15 years ago
Keywords: crash
(Reporter)

Comment 2

15 years ago
Ah. Yes -- it crashes when I try to download James, too. All the window says is
"The application Mozilla has unexpectedly quit. The system and other
applications have not been affected." Unfortunately, I don't get a crash log
either (did I happen to get some stunted build of Mozilla?)
I'll try the most recent version.

Comment 3

15 years ago
Christopher: Can you please repro the crash and post any error messages in the
console (make sure the console is cleared before the crash) here?
should be fixed by bug 213639 checkin.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

15 years ago
I've downloaded the latest release and checked this link again -- now works
fine. Yay!
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.