Closed Bug 21769 Opened 20 years ago Closed 20 years ago

Difficult to get to 4th addressing line in New Msg window

Categories

(MailNews Core :: Composition, defect, P3, major)

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 21280

People

(Reporter: esther, Assigned: bugzilla)

References

Details

Using builds from 12/13 and 12/14 the Addressing area of a Compose window is not
allowing the entry of a address in the 4th line without some difficulty.

1. Launch Messenger
2. Select New Msg
3. Enter a name in the 1st addressing line press <Enter> to get to the next
line, continue adding a name to the 2nd line, then 3rd line then <Enter>

Result: Focus is not moved to the 4th line, the 4th line doesn't even display
until you move the scroll bar up and down.  At this point you have to click the
cursor in that 4th line to add more addresses.
Expected:  After the <Enter> on the third line the cursor should move to the 4th
line and be ready for text entry.

Note: another bug deals with some of the addressee's not getting the message
(bug 21656) this bug is just for the easier access to more than 3 addressing
lines in the Compose window.
Whiteboard: needs hyatt triage
Is this really a general tree bug?  needs triage from hyatt.
Assignee: hyatt → alecf
There should be an EnsureVisible function on the tree that will do this.

Do EnsureVisible on your new row and then set focus to the text field.

Reassigning to alecf, so that he can mark this as dependent on EnsureVisible.
Assignee: alecf → ducarroz
Depends on: 12985
what should I do with this now? back to ducarroz?
QA Contact: lchiang → esther
Status: NEW → ASSIGNED
Whiteboard: needs hyatt triage
Target Milestone: M13
In order to fix this problem, I need the EnsureVisible API. Alec, what the
status with this function? do you have an open bug for it?
yeah, I just added that as a dependant bug, see above, bug 12985
*** Bug 22079 has been marked as a duplicate of this bug. ***
Release Notes for M12.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 21280 ***
Status: RESOLVED → VERIFIED
verified dup
No longer depends on: 12985
Blocks: 12985
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.