long strings without spaces within tables expand set table width

RESOLVED INVALID

Status

()

Core
Layout: Tables
RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: J, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

a long string will expand the table width if it does not fit within the
specified table width.  see steps to reproduce the problem.

Reproducible: Always

Steps to Reproduce:
1. write a simple html file with a simple table with <table
width="350"><tr><td>...</td></tr></table>
2. within the table cel type a long string that contains no spaces that will
exceed the width of the table (350)
Actual Results:  
loaded the page and noticed the text does not wrap to suit the table but it
expands the table to suit the text

Expected Results:  
wrapped text at the table width

Comment 1

15 years ago
This is the correct behaviour. If the content of a table cell is bigger than the
specified size for the cell, it should expand the table.

-> INVALID.

Comment 2

15 years ago
INVALID as per comment #1
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 3

15 years ago
Since the reporter expects that the text is wrapped inside the table, it's a
dupe of bug 95067. 
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 4

15 years ago

*** This bug has been marked as a duplicate of 95067 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE

Comment 5

15 years ago
why a duplicate? the reporter says nothing about hyphens?

he just expects the table to be the width specified instead of the width of
the nonwrapping text.

Comment 6

15 years ago
Kai, read bug 95067 and check its dupes
No, this is simply invalid.  We're never going to change the table algorithm,
where the WIDTH attribute means and has always meant 'min-width'.  We might
change the line-breaking algorithm to break around hyphens (in fact, we should).
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.