mozilla.org graphic/link on Bugzilla pages: graphic does not load, link leads to server error

RESOLVED FIXED

Status

www.mozilla.org
General
RESOLVED FIXED
15 years ago
6 years ago

People

(Reporter: Bill Mason, Assigned: Dawn Endico)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030830 Firebird/0.6.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030830 Firebird/0.6.1+

If the mozilla.org header graphic is not cached on my system, it does not load
when in Bugzilla pages.  It also does not load if I right-click on the space
where it should be and choose "View Image".  If I already have the graphic
cached from a non-Bugzilla mozilla.org page, the graphic loads normally. 
LiveHTTPHeaders captures these headers as the graphic tries to load:

http://www.mozilla.org/images/mozilla-banner.gif

GET /images/mozilla-banner.gif HTTP/1.1
Host: www.mozilla.org
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b)
Gecko/20030830 Firebird/0.6.1+
Accept: image/png,image/jpeg,image/gif;q=0.2,*/*;q=0.1
Accept-Language: en-us,en;q=0.5
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 300
Connection: keep-alive
Referer:
http://mecha.mozilla.org/webtools/bugzilla/buglist.cgi?query_format=&short_desc_type=substring&short_desc=&product=Browser&product=Firebird&product=Tech+Evangelism&component=Accessibility+APIs&component=Arabic&component=Autocomplete&component=BiDi+Hebrew+%26+Arabic&component=Bookmarks&component=Browser-General&component=Build+Config&component=build-config&component=Chinese-Simplified&component=Chinese-Traditional&component=Complex+Text+Layout&component=Cookies&component=Czech&component=DOM+Abstract+Schemas&component=DOM+Core&component=DOM+Events&component=DOM+HTML&component=DOM+Inspector&component=DOM+Level+0&component=DOM+Load+and+Save&component=DOM+Mozilla+Extensions&component=DOM+Other&component=DOM+Style&component=DOM+to+Text+Conversion&component=DOM+Traversal-Range&component=DOM+Views+and+Formatting&component=Download+Manager&component=Downloading&component=Dutch&component=Editor%3A+Core&component=Editor%3A+CSS+Editor&component=Embedding%3A+ActiveX+Wrapper&component=Embedding%3A+APIs&component=Embedding%3A+Docshell&component=Embedding%3A+GRE+Core&component=Embedding%3A+GTK+Widget&component=Embedding%3A+Mac&component=Embedding%3A+Packaging&component=English+Other&component=English+US&component=Event+Handling&component=File+Handling&component=Form+Manager&component=Form+Submission&component=French&component=General&component=German&component=GFX&component=GFX%3A+BeOS&component=GFX%3A+Gtk&component=GFX%3A+Mac&component=GFX%3A+OS%2F2&component=GFX%3A+Win32&component=GFX%3A+Xlib&component=Hebrew&component=Help&component=History&component=History%3A+Global&component=History%3A+Session&component=Image+Blocking&component=Image%3A+GFX&component=Image%3A+Layout&component=ImageLib&component=Installer&component=Installer%3A+GRE&component=Installer%3A+MFCEmbed&component=Installer%3A+XPI+Packages&component=Installer%3A+XPInstall+Engine&component=Internationalization&component=IPC&component=Italian&component=Japanese&component=Java+APIs+for+DOM&component=Java+APIs+to+WebShell&component=Java+to+XPCOM+Bridge&component=Java-Implemented+Plugins&component=JavaScript+Console&component=JavaScript+Debugger&component=JavaScript+Engine&component=Keyboard%3A+Find+as+you+Type&component=Keyboard%3A+Navigation&component=Layout&component=Layout%3A+Block+%26+Inline&component=Layout%3A+Floats&component=Layout%3A+Fonts+and+Text&component=Layout%3A+Form+Controls&component=Layout%3A+HTML+Frames&component=Layout%3A+Misc+Code&component=Layout%3A+R+%26+A+Pos&component=Layout%3A+Tables&component=Layout%3A+View+Rendering&component=Live+Connect&component=Localization&component=Location+Bar&component=MathML&component=Menus&component=Networking&component=Networking%3A+Cache&component=Networking%3A+File&component=Networking%3A+FTP&component=Networking%3A+HTTP&component=Norwegian&component=OJI&component=Other&component=Page+Info&component=Parser&component=Password+Manager&component=Plug-ins&component=Polish&component=Ports%3A+Qt&component=Portuguese&component=Preferences&component=Preferences%3A+Backend&component=Print+Preview&component=Printing&component=Printing%3A+Xprint&component=Profile+Manager+BackEnd&component=Profile+Manager+FrontEnd&component=Profile+Migration&component=QuickLaunch+%28AKA+turbo+mode%29&component=RDF&component=Search&component=Security%3A+CAPS&component=Security%3A+General&component=Selection&component=Sidebar&component=Skinability&component=Spanish&component=SQL&component=String&component=Style+System&component=SVG&component=Tabbed+Browser&component=Talkback&component=Themes&component=Toolbars&component=Tracking&component=Viewer+App&component=ViewSource&component=Web+Services&component=X-remote&component=XBL&component=XML&component=XP+Apps&component=XP+Apps%3A+Autocomplete&component=XP+Apps%3A+Cmd-line+Features&component=XP+Apps%3A+Drag+and+Drop&component=XP+Apps%3A+GUI+Features&component=XP+Miscellany&component=XP+Toolkit%2FWidgets&component=XP+Toolkit%2FWidgets%3A+Menus&component=XP+Toolkit%2FWidgets%3A+Trees&component=XP+Toolkit%2FWidgets%3A+XUL&component=XPCOM&component=XPCOM+Registry&component=XPConnect&component=xpidl&component=XSLT&long_desc_type=substring&long_desc=&bug_file_loc_type=substring&bug_file_loc=&status_whiteboard_type=substring&status_whiteboard=&keywords_type=anywords&keywords=&emailassigned_to1=1&emailtype1=substring&email1=&emailreporter2=1&emailtype2=substring&email2=&bugidtype=include&bug_id=&votes=&changedin=1&chfield=%5BBug+creation%5D&chfieldfrom=&chfieldto=Now&chfieldvalue=&cmdtype=doit&remaction=run&namedcmd=Release+blockers&order=Reuse+same+sort+as+last+time&field0-0-0=noop&type0-0-0=noop&value0-0-0=

HTTP/1.x 400 Bad Request
Server: Netscape-Enterprise/3.6
----------------------------------------------------------

Whether it loads or not, clicking on the link leads to a page that only says
"Your browser sent a message this server could not understand."  LiveHTTPHeaders
captures these headers when I follow the link:

http://www.mozilla.org/

GET / HTTP/1.1
Host: www.mozilla.org
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b)
Gecko/20030830 Firebird/0.6.1+
Accept:
text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,video/x-mng,image/png,image/jpeg,image/gif;q=0.2,*/*;q=0.1
Accept-Language: en-us,en;q=0.5
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 300
Connection: keep-alive
Referer:
http://mecha.mozilla.org/webtools/bugzilla/buglist.cgi?query_format=&short_desc_type=substring&short_desc=&product=Browser&product=Firebird&product=Tech+Evangelism&component=Accessibility+APIs&component=Arabic&component=Autocomplete&component=BiDi+Hebrew+%26+Arabic&component=Bookmarks&component=Browser-General&component=Build+Config&component=build-config&component=Chinese-Simplified&component=Chinese-Traditional&component=Complex+Text+Layout&component=Cookies&component=Czech&component=DOM+Abstract+Schemas&component=DOM+Core&component=DOM+Events&component=DOM+HTML&component=DOM+Inspector&component=DOM+Level+0&component=DOM+Load+and+Save&component=DOM+Mozilla+Extensions&component=DOM+Other&component=DOM+Style&component=DOM+to+Text+Conversion&component=DOM+Traversal-Range&component=DOM+Views+and+Formatting&component=Download+Manager&component=Downloading&component=Dutch&component=Editor%3A+Core&component=Editor%3A+CSS+Editor&component=Embedding%3A+ActiveX+Wrapper&component=Embedding%3A+APIs&component=Embedding%3A+Docshell&component=Embedding%3A+GRE+Core&component=Embedding%3A+GTK+Widget&component=Embedding%3A+Mac&component=Embedding%3A+Packaging&component=English+Other&component=English+US&component=Event+Handling&component=File+Handling&component=Form+Manager&component=Form+Submission&component=French&component=General&component=German&component=GFX&component=GFX%3A+BeOS&component=GFX%3A+Gtk&component=GFX%3A+Mac&component=GFX%3A+OS%2F2&component=GFX%3A+Win32&component=GFX%3A+Xlib&component=Hebrew&component=Help&component=History&component=History%3A+Global&component=History%3A+Session&component=Image+Blocking&component=Image%3A+GFX&component=Image%3A+Layout&component=ImageLib&component=Installer&component=Installer%3A+GRE&component=Installer%3A+MFCEmbed&component=Installer%3A+XPI+Packages&component=Installer%3A+XPInstall+Engine&component=Internationalization&component=IPC&component=Italian&component=Japanese&component=Java+APIs+for+DOM&component=Java+APIs+to+WebShell&component=Java+to+XPCOM+Bridge&component=Java-Implemented+Plugins&component=JavaScript+Console&component=JavaScript+Debugger&component=JavaScript+Engine&component=Keyboard%3A+Find+as+you+Type&component=Keyboard%3A+Navigation&component=Layout&component=Layout%3A+Block+%26+Inline&component=Layout%3A+Floats&component=Layout%3A+Fonts+and+Text&component=Layout%3A+Form+Controls&component=Layout%3A+HTML+Frames&component=Layout%3A+Misc+Code&component=Layout%3A+R+%26+A+Pos&component=Layout%3A+Tables&component=Layout%3A+View+Rendering&component=Live+Connect&component=Localization&component=Location+Bar&component=MathML&component=Menus&component=Networking&component=Networking%3A+Cache&component=Networking%3A+File&component=Networking%3A+FTP&component=Networking%3A+HTTP&component=Norwegian&component=OJI&component=Other&component=Page+Info&component=Parser&component=Password+Manager&component=Plug-ins&component=Polish&component=Ports%3A+Qt&component=Portuguese&component=Preferences&component=Preferences%3A+Backend&component=Print+Preview&component=Printing&component=Printing%3A+Xprint&component=Profile+Manager+BackEnd&component=Profile+Manager+FrontEnd&component=Profile+Migration&component=QuickLaunch+%28AKA+turbo+mode%29&component=RDF&component=Search&component=Security%3A+CAPS&component=Security%3A+General&component=Selection&component=Sidebar&component=Skinability&component=Spanish&component=SQL&component=String&component=Style+System&component=SVG&component=Tabbed+Browser&component=Talkback&component=Themes&component=Toolbars&component=Tracking&component=Viewer+App&component=ViewSource&component=Web+Services&component=X-remote&component=XBL&component=XML&component=XP+Apps&component=XP+Apps%3A+Autocomplete&component=XP+Apps%3A+Cmd-line+Features&component=XP+Apps%3A+Drag+and+Drop&component=XP+Apps%3A+GUI+Features&component=XP+Miscellany&component=XP+Toolkit%2FWidgets&component=XP+Toolkit%2FWidgets%3A+Menus&component=XP+Toolkit%2FWidgets%3A+Trees&component=XP+Toolkit%2FWidgets%3A+XUL&component=XPCOM&component=XPCOM+Registry&component=XPConnect&component=xpidl&component=XSLT&long_desc_type=substring&long_desc=&bug_file_loc_type=substring&bug_file_loc=&status_whiteboard_type=substring&status_whiteboard=&keywords_type=anywords&keywords=&emailassigned_to1=1&emailtype1=substring&email1=&emailreporter2=1&emailtype2=substring&email2=&bugidtype=include&bug_id=&votes=&changedin=1&chfield=%5BBug+creation%5D&chfieldfrom=&chfieldto=Now&chfieldvalue=&cmdtype=doit&remaction=run&namedcmd=Release+blockers&order=Reuse+same+sort+as+last+time&field0-0-0=noop&type0-0-0=noop&value0-0-0=

HTTP/1.x 400 Bad Request
Server: Netscape-Enterprise/3.6
----------------------------------------------------------

Reproducible: Always

Steps to Reproduce:
1. Clear the cache
2. Visit the URL given above.
3. Click where the mozilla.org header image should have rendered to try to
follow the link.

Actual Results:  
The mozilla.org header image did not load.  The link returned a server error.


I can reproduce this in Mozilla 2003090204 PC/Win2k, and Opera 7.11.  It does
not occur in IE6.

I have also reproduced it on a WinXP machine with Firebird 20030830, Mozilla
20030901 and Opera 7.11.

I reported it as a bug in this category instead of as a Browser bug since I can
reproduce the same issue in Opera 7.
Neil: now see what you did?  ;-)

Actually, I think this was broke before, too, I can reproduce this on the old
URL as well.

The Referer header appears to be what's breaking it.  MSIE likes to limit the
size of the URLs.  That's probably why it escapes this.  If I telnet in
manually, and trim the refering URL to be under 4096 characters, it works.

Section 3.2.1 of RFC 2616 says:

The HTTP protocol does not place any a priori limit on the length of
a URI. Servers MUST be able to handle the URI of any resource they
serve, and SHOULD be able to handle URIs of unbounded length if they
provide GET-based forms that could generate such URIs. A server
SHOULD return 414 (Request-URI Too Long) status if a URI is longer
than the server can handle (see section 10.4.15).

Based on this, I would say Netscape Enterprise Server is broken.

This will probably be fixed when the website gets moved to the new server (which
is Apache).
Depends on: 215280

Comment 2

15 years ago
Ah, but this way, the banner is more likely to be cached, because it's used in
more places :-P

Comment 3

15 years ago
Apache has its own limits. See 
<http://httpd.apache.org/docs-2.0/mod/core.html#limitrequestline>. It's 
8190 by default which is larger but not infinite. Can bugzilla generate 
a request that size?
The URL in the Referer header on this snippet is actually 4613 characters, and
it has a LOT of stuff in it off the query page, so it's probably safe to say
they won't get much bigger than that.
OK, verified, Apache does handle this condition just fine. :)
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Product: mozilla.org → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.