Status

()

defect
--
major
RESOLVED DUPLICATE of bug 162871
16 years ago
16 years ago

People

(Reporter: mikel, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
When a host's IP address changes, Mozilla Firebird continues to use the old
IP address associated with the host.

This manifests itself with my home page which is hosted on a service with a
dynamic IP address.  If I have Firebird open for more than a few hours, I get
a "connection refused" dialog when attempting to view my home page, presumably
because my home page's IP address has changed, yet Firebird has not realized
this.

I suspect Mozilla must use a DNS cache, however it must be badly broken
because:
a) a long period (even 30 minutes or an hour) after the DNS record has been
   updated, Firebird still uses the old IP address
b) the A records for this host have a TTL of 60 seconds, so Mozilla should
   not be caching the records for this period anyway

I am not sure why Mozilla has a DNS cache at all (surely this should be
implemented in the operating system if at all), but perhaps I am just annoyed
that its (IMO buggy) behavior stops my home page from working.

An advanced/hidden user option to specify a lower TTL or to manually clear
the DNS cache is far from a satisfactory solution, if indeed these exist or
are to be proposed.  Host resolution should work correctly by default.
(Reporter)

Comment 1

16 years ago
This appears to be the same issue as mentioned in bug 162871.

It sounds like it is going to be resolved for Mozilla 1.5 (despite
being targeted for Mozilla 1.6 :-/).  This will be most welcome!


*** This bug has been marked as a duplicate of 162871 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.