All users were logged out of Bugzilla on October 13th, 2018

doctor.cgi provides non-working bugzilla link for creating a bug to get new cvs account

RESOLVED FIXED

Status

--
minor
RESOLVED FIXED
15 years ago
2 years ago

People

(Reporter: bmo, Assigned: myk)

Tracking

Trunk
x86
Windows XP

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

when Doctor gives you the "Doctor - review changes to 
http://www.mozilla.org/blah/blah.html" page, it provides the following link:
http://bugzilla.mozilla.org/enter_bug.cgi?product=mozilla.org&component=CVS+Account+Request&version=other&rep_platform=All&op_sys=All&short_desc=webtree+CVS+account+for+%3Cyour+name+here%3E+-+%3Cyour+email+address+here%3E&comment=%3CEnter+a+description+of+what+you+would+like+to+edit+on+the+web+site+here.++Note%0D%0Athat+you+need+someone+who+already+has+access+to+vouch+for+you.%3E

this link doesn't behave as expected.


Reproducible: Always

Steps to Reproduce:
(Assignee)

Comment 1

15 years ago
What went wrong?
I just tested it...   it doesn't work if you don't have canconfirm privs,
because it dumps you into the guided version of enter_bug, and the guided
version apparently doesn't pre-fill from the passed parameters (other than product)
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

15 years ago
Depends on: 218219
(Assignee)

Comment 3

15 years ago
It should be possible to specify the non-guided version even for users without
canconfirm via the format parameter.  I've filed bug 218219 on that.
No longer depends on: 218219
(Assignee)

Comment 4

15 years ago
I hacked support for specifying the default format (bug 218219) into b.m.o and
updated the links in Doctor to do the right thing:

Checking in review.tmpl;
/cvsroot/mozilla/webtools/doctor/templates/review.tmpl,v  <--  review.tmpl
new revision: 1.8; previous revision: 1.7
done
(Assignee)

Comment 5

15 years ago
Fixed by that checkin.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
QA Contact: asa → doctor
Product: Webtools → Webtools Graveyard
You need to log in before you can comment on or make changes to this bug.