Add bookmark appears to hang browser

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
RESOLVED WORKSFORME
15 years ago
12 years ago

People

(Reporter: Phil Wells, Assigned: Pierre Chanial)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

I have a fairly extensive "Imported IE Favorites" with 30+ groups with multiple
groups being 3-4 levels deep.

When I select Add Bookmarks ..., (ctrl-D), Right-Click->Bookmark This Page, the
application stops responding long enough for me to think that it's hung (I've
restarted Firebird a couple of times before I decided to wait it out and see if
it ever came back).

Eventually, it comes back (approx 60 seconds) and lets me select the boookmark
group - apparently it was filling the drop down box.  Even with my imported
favorites list, it seems like an awful long time to sort through a hundred or so 
entries.

That's problem number 1.

Problem number 2 is if I do it again immediately, it again hangs for 60 seconds.
 Seems like this is a prime candidate for caching the drop down list.



Reproducible: Always

Steps to Reproduce:
1. Just press ctrl-D
2.
3.

Actual Results:  
Firebird stops responding for ~60 seconds.

Expected Results:  
Not taken more than a second or so.
This was an issue with IE bookmark parsing, fixed since 0.6.1

*** This bug has been marked as a duplicate of 205129 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
verified duplicate with 2003-09-26 W2K-build.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

15 years ago
This is still a problem in .7.  Adding a bookmark takes 45-60 seconds on a 1.3
ghz processor at 100%.

Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---
pch, would this be separate from the process followed on startup to initially
build these menus (that you fixed in 205129).  Maybe the dialog has the same
bottleneck?
temporariliy resolving as WFM, please retest with a current nightly including
the new add bookmark code and reopen if necessary
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WORKSFORME
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.