If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

rar files cannot be downloaded, are opened as gibberish

RESOLVED DUPLICATE of bug 220807

Status

Core Graveyard
File Handling
RESOLVED DUPLICATE of bug 220807
14 years ago
a year ago

People

(Reporter: Aditya N, Assigned: Bill Law)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030827
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030827

any compressed .rar files are opened by mozilla instesd of being downloaded,
nspite of having a corporate version of winrar installed and configured in the
helper applications section of 'preferences'. As far as i know, this is not due
to any changes made by me, as i have reinstalled mozilla on a new copy of winxp
and not changed the defaults. these rar files come out as gibberish, and as some
sites disable the 'save as' feature, it becomes impossible to download. it works
with any .rar file, so no need of me to list a webpage

Reproducible: Always

Steps to Reproduce:
1.click on the link
2.
3.

Actual Results:  
a page full of gibberish opened up, the textual version of the .rar file

Expected Results:  
displayed the option window asking to open via default application or save to disc

Theme: Pinball (same problem with the rest)
Computer config: P4 2.6C, Geforce FX5900 ultra, Soundblaster live, Windows Xp
(not sp1), 512 mb ddr, 120 gb hdd

Comment 1

14 years ago
Yes, you do need to list a URL.  It's most like that the site is serving the RAR
file as text/plain, so Mozilla treats it as text like it's been told to.

If you search Bugzilla, you will find several bugs on RAR files served
incorrectly as text/plain.
http://mecha.mozilla.org/webtools/bugzilla/buglist.cgi?query_format=&short_desc_type=allwords&short_desc=rar&product=Tech+Evangelism&long_desc_type=substring&long_desc=&bug_file_loc_type=allwordssubstr&bug_file_loc=&status_whiteboard_type=allwordssubstr&status_whiteboard=&keywords_type=allwords&keywords=&emailassigned_to1=1&emailtype1=exact&email1=&emailassigned_to2=1&emailreporter2=1&emailqa_contact2=1&emailtype2=exact&email2=&bugidtype=include&bug_id=&votes=&changedin=&chfieldfrom=&chfieldto=Now&chfieldvalue=&cmdtype=doit&remaction=run&namedcmd=Release+blockers&order=Reuse+same+sort+as+last+time&field0-0-0=noop&type0-0-0=noop&value0-0-0=

Without a URL, this bug should be resolved invalid for lack of information.

Comment 2

14 years ago
No response from reporter -> IMHO this could be marked as INVALID.
(Reporter)

Comment 3

14 years ago
well, as this is shown to be a fault of the website designer, it should be
passed on as a bug. But the fact remains that this is going to be an
inconvenience to many. Ie does not give problems, but mozilla does. While this
may be pretty biased, not being able to do the things IE can, being able to
render stuff which IE can properly, may be a major pitfall in the adaptation of
mozilla by its end users. 

Comment 4

14 years ago
Should be better with this fix in Moz 1.7a/FB 0.8 builds.

Handling of Files with text/plain MIME Type

By default, Apache serves unrecognized files with a text/plain MIME type. As a
result, Mozilla now asks the user what to do when it encounters a file with a
MIME type of either text/plain, text/plain; charset=ISO-8859-1 or text/plain;
charset=iso-8859-1 (bug 220807).

Reporter, can you give us an example URL?

*** This bug has been marked as a duplicate of 220807 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.