Closed Bug 218401 Opened 20 years ago Closed 19 years ago

Term "Bug" in query.cgi is not templatized in some places

Categories

(Bugzilla :: User Interface, defect)

defect
Not set
minor

Tracking

()

RESOLVED FIXED
Bugzilla 2.18

People

(Reporter: andreas.hoefler, Assigned: andreas.hoefler)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a; MultiZilla v1.5.0.2Beta) Gecko/20030830
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a; MultiZilla v1.5.0.2Beta) Gecko/20030830

On the query-page header there is the choice between "Advanced Search" and "Find
a specific Bug"

The term "Bug" is not templatized and replaced if "Bug" is changed to for
example "Task" in variables.none.tmpl

Reproducible: Always

Steps to Reproduce:
1. Change Terms in variables.none.tmpl
2.
3.

Actual Results:  
Text is "Find a specific Bug"

Expected Results:  
Text should be "Find a specific Task"
"Bug" also still appears in the first drop-down of the "Advanced Querying Using
Boolean Charts".

There are: "Bug #", "BugsThisDependsOn", "OtherBugsDependingOnThis" and "Days
since bug changed".

Furthermore if the "Find a specific Bug"-version of query.cgi is used, there are
more occourences of "bug" and "Bugzilla".
Summary: String "Bug" in query.cgi in text "Find a specific Bug" is not templatized → Term "Bug" in query.cgi is not templatized in some places
The "Bug #" in the first dropdown in the advanced query section is not actuall a
"Bug term" but the name of a field.  That would need to be changed in
global/field-descs.none.html 
Status: UNCONFIRMED → NEW
Ever confirmed: true
This makes the "Bug" text on the tabs dynamic.
Attachment #131092 - Flags: review?
Severity: normal → minor
OS: Windows 2000 → All
Hardware: PC → All
Target Milestone: --- → Bugzilla 2.20
Attachment #131092 - Flags: review? → review+
Assignee: myk → andreas.hoefler
Flags: approval?
Target Milestone: Bugzilla 2.20 → Bugzilla 2.18
Flags: approval? → approval+
Checking in template/en/default/search/tabs.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/search/tabs.html.tmpl,v 
<--  tabs.html.tmpl
new revision: 1.3; previous revision: 1.2
done
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.