Need shortcut to break nasty scripts

VERIFIED DUPLICATE of bug 61098

Status

()

Core
JavaScript Engine
--
enhancement
VERIFIED DUPLICATE of bug 61098
14 years ago
10 years ago

People

(Reporter: Johan Buret, Assigned: rogerl (gone))

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

If you develop some hairy Javascript, it is too easy to mess up the code and
make infinite loops.
So, in each way, there is a need of break.

It is a request for enhancement, but IMHO it qualifies for a major bug

Reproducible: Always

Steps to Reproduce:
1.Be sure to have 'Javascript Enabled'
2.Right-Click on the link and 'save link as...' to get the code (and the joke BTW).
3.Open the page (if you really want too)
Actual Results:  
No way to get out this (censored) script. All is disabled except the popup.

Expected Results:  
Provide a way out of this mess

Tested on Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030624 too

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 61098 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 2

14 years ago
Verified Duplicate -
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.