display chinese some in disorder.

RESOLVED FIXED

Status

--
major
RESOLVED FIXED
15 years ago
10 years ago

People

(Reporter: zzw6789, Assigned: blizzard)

Tracking

({intl})

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030827 Debian/1.4-3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030827 Debian/1.4-3

open website www.gzlinux.org, you will see that it display chinese some in
correct, some are disorder! the disorder often has english charecter and chinese
charect in same line. 

Reproducible: Always

Steps to Reproduce:
1.run mozilla from menu
2.input www.gzlinux.org
3.display the web page

Actual Results:  
display some chinese in disorder!

Expected Results:  
display chinese  correctly!

I attach a screenshot for ref.
(Reporter)

Comment 1

15 years ago
Created attachment 131060 [details]
display chinese in disorder!

Comment 2

15 years ago
I guess this('crushed-down' rendering of bitmap glyphs when they're in the same
'line' with anti-aliased glyphs) is due to an Xft bug that has been fixed
recently. Can you install the newest Xft package for Debian and see if this
problem goes away?
Component: Browser-General → GFX: Gtk
Keywords: intl
.
Assignee: general → blizzard
QA Contact: general → ian
(Reporter)

Comment 4

15 years ago
I update mozilla-xft for newest version, It still have this problem. now Mozilla
version is Debian Package 1.4-4.

Comment 5

15 years ago
I reported this 'crashed rendering' a few days ago

http://bugs.xfree86.org/show_bug.cgi?id=649
http://fontconfig.org/cgi-bin/bugzilla/show_bug.cgi?id=102

and I found this bug is fixed on the Xft2 2.1.2

you can simply test it with the following steps:
 0. download Xft 2.1.2
http://pdx.freedesktop.org/~fontconfig/release/xft-2.1.2.tar.gz
 1. backup your old libXft.so.2*
 2. build the new Xft 2.1.2 
 3. replace old libXft.*
 4. run the mozilla
(Reporter)

Comment 6

15 years ago
thanks a lot! I resolve the problem with you method! thanks the works done by
all people of open source!
(Reporter)

Comment 7

15 years ago
update XFT to 2.1.1, and mozilla-xft can display chinese correctly!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.