Style float on a TD causes the cursor to be out of a input text

RESOLVED DUPLICATE of bug 233094

Status

()

RESOLVED DUPLICATE of bug 233094
16 years ago
15 years ago

People

(Reporter: philippe, Unassigned)

Tracking

({regression, testcase})

Trunk
x86
All
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030908 Firebird/0.6.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030908 Firebird/0.6.1+

The test case shows that the place of the cursor (and of the typed text) to be
miscalculated in both X and Y (eg X more visible inside of a centered DIV).
The style causing the problem is { float: left; width : 100%; }


Reproducible: Always

Steps to Reproduce:
1. click on the first text input field
2. type some characters


Actual Results:  
1. look at the position of the cursor and the typed text
2. they are out of the input text box

Expected Results:  
Leave the cursor inside of the selected input text

The original HTML comes from the PHP Mantis application (a bug tracking system
hosted at SourceForge).
Posted file Testcase
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
OS: Windows XP → All

Comment 2

16 years ago
This works in Quirks mode.
I see the same bug in Quirks mode too.

Comment 4

16 years ago
Also results in SELECT dropdown lists not rendering. Does not occur in Firebird
0.6, only 0.6.1
Someone on the forums saw this bug on the FilmCritic site. If this bug is
related, then it is present in Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7a)
Gecko/20040107 Firebird/0.7+ (daihard; XFT+GTK2; optimized for P4/SSE-2)

Code fragment:

<td class="searchsite" width="22%">
 <p>
 <TABLE BORDER=0 CELLSPACING=1 CELLPADDING=1>
  <TR VALIGN=top>
   <TD WIDTH="144">
    <B><FONT SIZE=2><center>Search the Site</center></FONT></B>
   </TD>
   <TD WIDTH="34">
    <FORM METHOD="POST" TARGET=""
ACTION="http://filmcritic.com/misc/emporium.nsf/84dbbfa4d710144986256c290016f76e?SearchView">
   </TD>
  </TR>
  <TR VALIGN=top>
   <TD WIDTH="144">
     <input name="Query" size=20 VALUE="search filmcritic.com" 
onclick="this.value=''">
   </TD>
   <TD WIDTH="34">
     <input type=image border=0 alt="Click here to search"
src="/misc/mepics.nsf/view/trianglespc/$File/trianglespc.gif">
     </form>
   </TD>
  </TR>
 </TABLE>
</td>

That </form> tag inside the second set of <TR> tags looks interesting.

Link to thread: http://forums.mozillazine.org/viewtopic.php?t=44397

Updated

15 years ago
Keywords: regression

Comment 7

15 years ago
This is fixed now. Suspect bug 233094 to have fixed it, duping.

*** This bug has been marked as a duplicate of 233094 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.