port nsSystemPref to windows for internet options

RESOLVED WONTFIX

Status

()

Core
Networking
--
enhancement
RESOLVED WONTFIX
15 years ago
2 years ago

People

(Reporter: Martin Hajduch, Assigned: ericjung)

Tracking

Trunk
x86
Windows XP
Points:
---
Bug Flags:
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

windows internet options (dialer) together with internet explorer, they have one
graeat thing - one can define separate proxy server for every dialup connection

i have two internet providers, one of them with (mandatory) and one without a
proxy server, and i'm also dialing to work where we have another proxy server
(also mandatory)

currently, i always have go into options->connection and type in the right proxy
whenever i change the connection

would it be possible to add a possibility so that firebird (when running on
windows) could take the proxy from windows internet connection settings (for the
currently active connection) ???

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago
What you want is two different profiles with different proxy settings. But it
would sure be nice to import the proxy settings directly from the internet options.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

15 years ago
even with two (or more) profiles, one still have to:

- first, select which connection he wants to use
- second, select corresponding profile

then, profile stores much more information than only proxy - so it starts to be
complicated

i don't know what do you exactly mean by 'importing' but i was talking about
something like 'runtime importing'

i.e. - when you open the browser, it checks which proxy should be currently used;
but if you during the browsing close that connection, and open another one,
which has another proxy server, browser automatically detects this and you
continue browsing as if nothing would happen (this is the way how IE works)

is this possible ?

Updated

15 years ago
QA Contact: asa

Comment 3

14 years ago
I wanted to add some hopefully helpful information about this (beats duplicating
the bug, right?).

First, I wanted to note the somewhat recent trend of an OS-centric proxy
setting.  I've noticed that Red Hat 9, Windows (any version), and Mac OS X seem
to place the proxy setting in a centrally-available place.  This is so a user
can (ideally) change the proxy in one place and have that change propagate
across several applications.  This is a Good Idea (TM).

Ironically, in order to use my favorite browser in the world in a real-life
scenario, I have to change my proxy settings twice (once for
IE/RealPlayer/iTunes Music Store/etc. and once for Firebird).  Since I'm using a
laptop and bringing the computer between home, work, and school, this makes
setting my proxy a twice-daily eye-rolling experience.

It Would Be Nice (R) if I could change the proxy setting in Mozilla Firebird and
have that change written to the registry, or if I could have a radio button in
Mozilla Firebird that said something to the effect of "Use system proxy settings."

My firewall settings seem to be saved here in the registry (Win2K):
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet
Settings\ProxyServer

I hope this helps prioritize an issue that I've been hoping for since the early
days of Phoenix v0.2. :)

Comment 4

14 years ago
I agree with Ken : not only Windows XP, but other modern platforms (MacOS X
which I use, Linux) should added as target OS for this bug.

Comment 5

14 years ago
There are bugs for Unix (bug 66057) and MacOS (bug 125995). They block the
Metabug 139393, which itself is blocking the bug for the Seamonkey UI: bug 218944.

I propose to make this bug also dependent on bug 139393.

Comment 6

14 years ago
Here is the registry settings:  
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\

UseProxy : REG_DWORD If value is set to 1, the browser accesses the Internet
through a proxy server.  
ProxyServer : REG_SZ Set to name of the proxy server. 

The ProxyServer value is either one host or protocol=host, if proxies are used
per protocol.

I would think the new shellservice component would be ideal for this and if the
registry values are not found, it could fall back to prefs.

Comment 7

14 years ago
This would be a very useful feature (especially for users like myself who travel
from site to site that have different proxies set up) is to have the option (on
Windows platform only) to use the proxy settings specified in the Internet
Options control panel applet.

This would then allow Mozilla/Firefox to work with many different programs that
automatically change the Internet Options based on a selected location profile
(such as IBM Access Connections).

This would be very, very useful.

Comment 8

14 years ago
Ben, is this something we can pull in with IE migration? I think it'd be a huge
win if we could. It looks like a pretty straight-forward registry setting.
Flags: blocking-aviary1.0?

Comment 9

14 years ago
Asa, FYI, my ideal use-case would be in an ongoing scenario (such as every time
I start up FireFox, it would import IE's proxy settings).  I think you might be
thinking of a one-time situation when users first install FireFox...

Updated

14 years ago
Flags: blocking-aviary1.0? → blocking-aviary1.0+

Comment 10

14 years ago
Ken, yeah. If we can, it's be nice to just pull proxy settings from the system
when ever we start. At a bare minimum, though, a one time import would be an
improvement over what we have now and would be a big usability win for people
migrating from IE. 

Comment 11

14 years ago
We just got a fix for bug 28998
We do import this during migration from IE, but getting this live from the
system would be nicer.

Updated

14 years ago
Flags: blocking-aviary1.0+ → blocking-aviary1.0-

Updated

14 years ago
Blocks: 241532

Comment 13

13 years ago
Perhaps a bit off topic, but I do not consider my request worth opening a new
ticket: To work from home I must connect to the company network using a VPN. But
Windows doesn't let me use my direct connection to the Internet while I'm on the
VPN so I have to configure Firefox to use the company proxy. That's ok. What I
dont't like though is that when I disconnect from the VPN Firefox can't connect
to the proxy anymore and then I get a dialog that tells me "The proxy
server[...] not found [...]". I would like Firefox to fallback to direct
connection mode without requiring that I go set the connection settings again.
If, for some reason, this is not acceptable behaviour for a browser then a
second option could be added to the error dialog: "Try direct connection
[...]"... You get the Idea.
Assignee: bross2 → nobody
QA Contact: general

Comment 14

10 years ago
comment 5 is woefully incomplete. could someone actually document the full list? msdn urls are relatively ok,.

AutoConfigProxy wininet.dll -- i assume this means that some third party can provide an alternative

http://msdn2.microsoft.com/en-us/library/aa374958(VS.85).aspx
http://blogs.msdn.com/nunos/archive/2004/03/12/88473.aspx
http://www.tomshardware.com/forum/88146-45-auto-proxy-detection

please also keep in mind that you can have per dialup connection proxy settings. So if someone could find documentation for that, it'd also be appreciated.

wininet:
http://msdn2.microsoft.com/en-us/library/aa385473(VS.85).aspx

autoproxy:
http://msdn2.microsoft.com/en-us/library/aa383910(VS.85).aspx
(complete with sample code!)

offhand, i think the proper behavior is something like:
1. grab the AutoConfigProxy setting
2. LoadLibrary it
3. GetProcAddress for:
    DetectAutoProxyUrl
http://msdn2.microsoft.com/en-us/library/aa383993(VS.85).aspx

InternetDeInitializeAutoProxyDll
InternetGetProxyInfo
InternetInitializeAutoProxyDll

not that wininet autoproxy was deprecated in favor of
WinHTTP AutoProxy Support
http://msdn2.microsoft.com/en-us/library/aa384240(VS.85).aspx

--
note: there are various ways to do this, one approach is to just poach registry settings ad hoc. this works until someone complains we missed a bunch.

e.g. the dialup, or per user, or system policies.

the other obvious approach is to use the API.

this works until the APIs crash :) [if you don't think that happens, please volunteer to help fix bugs caused by various crashing external APIs, I can point to many, or you could just trust me].

Sadly, I don't think that autoproxy actually does anything beyond PAC, if I'm wrong, would someone please correct me?
Component: General → Networking
Product: Firefox → Core
QA Contact: general → networking
Summary: getting proxy server from windows internet options (separate for every connection) → port nsSystemPref to windows for internet options
Version: unspecified → Trunk
(Assignee)

Updated

10 years ago
Assignee: nobody → eric.jung
not investing more in dialer
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.