If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Wrong mime-types from lousy servers should be ignored

RESOLVED DUPLICATE of bug 210229

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 210229
14 years ago
14 years ago

People

(Reporter: Daniel Kjøller Skovenborg, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030911 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030911 Mozilla Firebird/0.6.1

Try to open http://members.aol.com/tourniqt/headingss.htm in Firebird. You'll
get the message:
 The file "headingss.htm" is of type iso-8859-1 (HyperText Markup Language), and
Mozilla Firebird does not know how to handle this file type."
A web-browser that doesn't knows HTML-files? :)
I have been told it's because the server sends the wrong mime-type (should be
text/html). I know idiotic sites and servers should be punished, but anyway: Why
not look at the file-extensions and give the opportunity to open it in the
current Firebird-session with mime-type set to text/html?

Saying "Open with /usr/local/MozillaFirebird" is not an option in this case:
After selecting another profile than the default (necessary because it's a new
session) it can't find the files it needs (headingss.htm specifies two frames
and the pages in the frames are expected to be in /tmp but they aren't).

Reproducible: Always

Steps to Reproduce:
- Open the URL http://members.aol.com/tourniqt/headingss.htm
or:
- Go to http://www.tourniquet.net and click on the "Skip Intro and Enter Site" link.
Actual Results:  
Dialogbox asking what to do with the file (unknown mime-type).

Expected Results:  
At least give the opportunity to ignore the stupid server-settings and open as
it is: text/html.

Comment 1

14 years ago
WFM 20030830 PC/WinXP

This was fixed previously in bug 210229 on 31 July 2003.

If this can be confirming as happening by someone, then there's been some sort
of regression of that bug.

Comment 2

14 years ago
Still WFM after updating to 20030911 PC/WinXP.

Comment 3

14 years ago
this WFM too.

Reporter, if you still see this bug reopen 210229.

*** This bug has been marked as a duplicate of 210229 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.