Mozilla crashes when no Local Folders are available [@ nsVoidArray::Count()]

RESOLVED WORKSFORME

Status

MailNews Core
Backend
--
critical
RESOLVED WORKSFORME
15 years ago
7 years ago

People

(Reporter: mcsmurf, Unassigned)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
First I have no Local Folders (better said: sub-folders of Local Folders), but
this doesn't seem to matter here (the Local Folders entry is still there but no
sub-folders). When I send a news article, Mozilla complains that it could not
copy the message to the Send folder and if I want to return to the compose
window. Doesn't matter if I now click on OK or Cancel, Mozilla crashes anyway.
The message   is posted to the news server without problems.
Stacktrace:
#0  0x41d467ff in nsVoidArray::Count() const (this=Cannot find thread 16384:
generic error
) at ../../../dist/include/xpcom/nsVoidArray.h:62
#1  0x41d6ff04 in ~nsCopyRequest (this=Error accessing memory address
0xbfffe9a0: Found no matching process.
) at /mozilla2/mozilla/mailnews/base/src/nsMsgCopyService.cpp:98
#2  0x41d705ad in nsMsgCopyService::ClearRequest(nsCopyRequest*, unsigned)
(this=Error accessing memory address 0xbfffe9c0: Found no matching process.
) at /mozilla2/mozilla/mailnews/base/src/nsMsgCopyService.cpp:188
#3  0x41d70b44 in nsMsgCopyService::DoNextCopy() (this=Error accessing memory
address 0xbfffea40: Found no matching process.
) at /mozilla2/mozilla/mailnews/base/src/nsMsgCopyService.cpp:327
#4  0x41d70751 in nsMsgCopyService::DoCopy(nsCopyRequest*) (this=Error accessing
memory address 0xbfffea70: Found no matching process.
) at /mozilla2/mozilla/mailnews/base/src/nsMsgCopyService.cpp:235
#5  0x41d719ec in nsMsgCopyService::CopyFileMessage(nsIFileSpec*, nsIMsgFolder*,
nsIMsgDBHdr*, int, nsIMsgCopyServiceListener*, nsIMsgWindow*) (this=Error
accessing memory address 0xbfffeaf0: Found no matching process.
) at /mozilla2/mozilla/mailnews/base/src/nsMsgCopyService.cpp:592
#6  0x41f73b39 in nsMsgCopy::DoCopy(nsIFileSpec*, nsIMsgFolder*, nsIMsgDBHdr*,
int, nsIMsgWindow*, nsIMsgSend*) (this=Error accessing memory address
0xbfffebb0: Found no matching process.
) at /mozilla2/mozilla/mailnews/compose/src/nsMsgCopy.cpp:313
#7  0x41f73651 in nsMsgCopy::StartCopyOperation(nsIMsgIdentity*, nsIFileSpec*,
int, nsIMsgSend*, char const*, nsIMsgDBHdr*) (this=Error accessing memory
address 0xbfffec10: Found no matching process.
) at /mozilla2/mozilla/mailnews/compose/src/nsMsgCopy.cpp:244
#8  0x41f6575b in nsMsgComposeAndSend::StartMessageCopyOperation(nsIFileSpec*,
int, char*) (this=Error accessing memory address 0xbfffec50: Found no matching
process.
) at /mozilla2/mozilla/mailnews/compose/src/nsMsgSend.cpp:4693
#9  0x41f65584 in nsMsgComposeAndSend::MimeDoFCC(nsFileSpec*, int, char const*,
char const*, char const*) (this=Error accessing memory address 0xbfffef30: Found
no matching process.
) at /mozilla2/mozilla/mailnews/compose/src/nsMsgSend.cpp:4660
#10 0x41f634df in nsMsgComposeAndSend::DoFcc() (this=Error accessing memory
address 0xbfffef70: Found no matching process.
) at /mozilla2/mozilla/mailnews/compose/src/nsMsgSend.cpp:3750
#11 0x41f63040 in nsMsgComposeAndSend::DoDeliveryExitProcessing(nsIURI*,
unsigned, int) (this=Error accessing memory address 0xbfffefc0: Found no
matching process.
) at /mozilla2/mozilla/mailnews/compose/src/nsMsgSend.cpp:3664
#12 0x41f630a5 in nsMsgComposeAndSend::DeliverAsNewsExit(nsIURI*, unsigned)
(this=Error accessing memory address 0xbfffefe0: Found no matching process.
) at /mozilla2/mozilla/mailnews/compose/src/nsMsgSend.cpp:3690
#13 0x41f611f0 in SendDeliveryCallback(nsIURI*, unsigned, nsMsgDeliveryType,
nsISupports*) (aUrl=Error accessing memory address 0xbffff030: Found no matching
process.
) at /mozilla2/mozilla/mailnews/compose/src/nsMsgSend.cpp:3243
#14 0x41f7a4b8 in nsMsgDeliveryListener::OnStopRunningUrl(nsIURI*, unsigned)
(this=Error accessing memory address 0xbffff080: Found no matching process.
) at /mozilla2/mozilla/mailnews/compose/src/nsMsgDeliveryListener.cpp:96
#15 0x41d42c7e in nsUrlListenerManager::BroadcastChange(nsIURI*,
nsUrlNotifyType, unsigned) (this=Error accessing memory address 0xbffff100:
Found no matching process.
) at /mozilla2/mozilla/mailnews/base/src/nsUrlListenerManager.cpp:107
#16 0x41d42d01 in nsUrlListenerManager::OnStopRunningUrl(nsIMsgMailNewsUrl*,
unsigned) (this=Error accessing memory address 0xbffff120: Found no matching
process.
) at /mozilla2/mozilla/mailnews/base/src/nsUrlListenerManager.cpp:123
#17 0x419cd5a3 in nsMsgMailNewsUrl::SetUrlState(int, unsigned) (this=Error
accessing memory address 0xbffff160: Found no matching process.
) at /mozilla2/mozilla/mailnews/base/util/nsMsgMailNewsUrl.cpp:132
#18 0x41a0f92e in nsNNTPProtocol::ProcessProtocolState(nsIURI*, nsIInputStream*,
unsigned, unsigned) (this=Error accessing memory address 0xbffff1c0: Found no
matching process.
) at /mozilla2/mozilla/mailnews/news/src/nsNNTPProtocol.cpp:5307
#19 0x419c62a3 in nsMsgProtocol::OnDataAvailable(nsIRequest*, nsISupports*,
nsIInputStream*, unsigned, unsigned) (this=Error accessing memory address
0xbffff210: Found no matching process.
) at /mozilla2/mozilla/mailnews/base/util/nsMsgProtocol.cpp:324
#20 0x40a94b33 in nsInputStreamPump::OnStateTransfer() (this=Error accessing
memory address 0xbffff290: Found no matching process.
) at /mozilla2/mozilla/netwerk/base/src/nsInputStreamPump.cpp:418
#21 0x40a94840 in nsInputStreamPump::OnInputStreamReady(nsIAsyncInputStream*)
(this=Error accessing memory address 0xbffff2c0: Found no matching process.
) at /mozilla2/mozilla/netwerk/base/src/nsInputStreamPump.cpp:321
#22 0x408baa21 in nsInputStreamReadyEvent::EventHandler(PLEvent*) (plevent=Error
accessing memory address 0xbffff2f0: Found no matching process.
) at /mozilla2/mozilla/xpcom/io/nsStreamUtils.cpp:116
#23 0x408d863b in PL_HandleEvent () from
/mozilla2/mozilla/obj-i686-pc-linux-gnu/dist/bin/libxpcom.so
#24 0x408d8525 in PL_ProcessPendingEvents () from
/mozilla2/mozilla/obj-i686-pc-linux-gnu/dist/bin/libxpcom.so
#25 0x408d9b26 in nsEventQueueImpl::ProcessPendingEvents() (this=Error accessing
memory address 0xbffff3a0: Found no matching process.
) at /mozilla2/mozilla/xpcom/threads/nsEventQueue.cpp:391
#26 0x41284df4 in event_processor_callback (data=Error accessing memory address
0xbffff3c0: Found no matching process.
) at /mozilla2/mozilla/widget/src/gtk/nsAppShell.cpp:187
#27 0x412848d1 in our_gdk_io_invoke (source=Error accessing memory address
0xbffff3f0: Found no matching process.
) at /mozilla2/mozilla/widget/src/gtk/nsAppShell.cpp:72
#28 0x402aeac6 in g_io_add_watch () from /usr/lib/libglib-1.2.so.0
#29 0x402b00b1 in g_get_current_time () from /usr/lib/libglib-1.2.so.0
#30 0x402b0568 in g_get_current_time () from /usr/lib/libglib-1.2.so.0
#31 0x402b0798 in g_main_run () from /usr/lib/libglib-1.2.so.0
#32 0x401d27f7 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#33 0x41285292 in nsAppShell::Run() (this=Error accessing memory address
0xbffff510: Found no matching process.
) at /mozilla2/mozilla/widget/src/gtk/nsAppShell.cpp:327
#34 0x4125fe11 in nsAppShellService::Run() (this=Error accessing memory address
0xbffff530: Found no matching process.
) at /mozilla2/mozilla/xpfe/appshell/src/nsAppShellService.cpp:483
#35 0x08063c61 in main1 (argc=Error accessing memory address 0xbffff6e0: Found
no matching process.
) at /mozilla2/mozilla/xpfe/bootstrap/nsAppRunner.cpp:1290
#36 0x0806475f in main (argc=Error accessing memory address 0xbffff720: Found no
matching process.
) at /mozilla2/mozilla/xpfe/bootstrap/nsAppRunner.cpp:1669
Error accessing memory address 0xbffff718: Found no matching process.
(Reporter)

Comment 1

15 years ago
Created attachment 131389 [details]
Error before crash

This error message appears, just before Mozilla crashes when you click OK or
Cancel

Comment 2

15 years ago
This worksforme with linux trunk 2003091105.

Are you saying that Local folders has no subfolders (no "Sent")?  I can't delete
them within Mozilla and if I delete them manually, they reappear in Mozilla

and what's this?
> argc=Error accessing memory address 0xbffff720: Found no matching process..
Summary: Mozilla crashes when no Local Folders are available[@nsVoidArray::Count()] → Mozilla crashes when no Local Folders are available [@ nsVoidArray::Count()]
(Reporter)

Comment 3

15 years ago
I deleted the Local Folders (the subfolders; or better said: I didn't copy them
yet from my old profile) with my filemanager (Windows Explorer,Konquerer,etc.).
But this bug isn't invalid because of this, because Mozilla recognizes that it
can't access the sub folder. But then it crashes.
> argc=Error accessing memory address 0xbffff720: Found no matching process..
sorry, don't know, copied this from gdb

Comment 4

15 years ago
if you're copying a profile from Windoze, you might look at the
mail.server.serverX.directory entries in your prefs.js to make sure none of them
point at invalid directories (like c:\something).  Also look at the
mail.root.XXX entries.
(Reporter)

Comment 5

15 years ago
Ok, i corrected some entrys. Now Mozilla doesn't complain anymore and saves it
correctly (but why does Mozilla notice the behavior before this and then crash?)

Comment 6

15 years ago
because c:\ is a relative path (doesn't start with '/') and probably bug 183871

this seems like a dupe of bug 183871, but I don't really know what's going on
with the stacktrace here
Depends on: 183871
(Reporter)

Comment 7

15 years ago
no the path was file:///home//[.....], nothing with \ in it.

Comment 8

15 years ago
so then what were the invalid entries that were causing the crash?  was it the:

file:///home//[.....]
            ^^
?
(Reporter)

Comment 9

15 years ago
hm, seems so. I corrected the path now, so Mozilla does find the Local Folders
(with the subfolders) again and everything works.

Comment 10

15 years ago
*** Bug 221633 has been marked as a duplicate of this bug. ***
Product: MailNews → Core
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody
Filter on "Nobody_NScomTLD_20080620"
QA Contact: esther → backend
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core

Comment 13

9 years ago
existing profile Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b4pre) Gecko/20090322 Shredder/3.0b3pre

I deleted "local folders", start- no crash
I deleted mail folder, stasrt - no crash

=> WFM
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsVoidArray::Count()]
You need to log in before you can comment on or make changes to this bug.