RFE: use PATH environement variable when specifying an application to open a downloaded file

VERIFIED DUPLICATE of bug 56662

Status

Core Graveyard
File Handling
--
enhancement
VERIFIED DUPLICATE of bug 56662
14 years ago
a year ago

People

(Reporter: Simon Anders, Assigned: Bill Law)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030718
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030718

When one downloads a file which Mozilla does not know how to handle, a dialog
box is pops up entitled "Opening <filename>".

If one chooses "Open it with ..." one has to type in the name of the executable
with its _full_path_.

It would be much more convenient if it sufficed to just enter the name of the
binary for those binaries which are in the standard search path, i.e. in the
paths listed in the PATH environment variable.

I hence suggest to check the PATH before reporting a binay as "not found".

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

14 years ago
Please search for duplicates before filing a new bug, thanks.
http://bugzilla.mozilla.org/query.cgi

See bug 56662 and bug 82860 (and many duplicates)



*** This bug has been marked as a duplicate of 56662 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
vrfy dup
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.