radio buttons wont change on refresh

VERIFIED DUPLICATE of bug 46845

Status

SeaMonkey
General
--
major
VERIFIED DUPLICATE of bug 46845
14 years ago
13 years ago

People

(Reporter: matt carpenter, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030913 Firebird/0.6.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030913 Firebird/0.6.1+

If I refresh a page after editing the HTML by moving the CHECKED attribute to a
different radio button, the same radio button still stays clicked. I have to
close mozilla out, then re-open it and bring up the page before the correct
radio button will appear checked.

Reproducible: Always

Steps to Reproduce:
1. add text in step 2 to an HTML document
2.<form method=get action=asetloggingenabled><font>Enable Logging <input
type=radio name=value value=true CHECKED> On <input type=radio name=value
value=false> Off</form>
3. Open in firebird. Notice how the first radio button is checked
4. Leave firebird open, edit the html document and move CHECKED from the first
radio button tag to the second.
5. Refresh page. Check hasn't moved.
6. Close Firebird then open it up and load the page. Check has now moved.

Actual Results:  
Check in radio buttons didn't move until I reloaded firebird

Expected Results:  
Firebird should've moved the check from radio button 1 to radio button 2 after I
hit refresh.

Comment 1

14 years ago
This is because mozilla stores user entered form data between refreshes. The
editing described is a bit like a user click on a different checkbox (but kinda
in reverse). Use shift-reload and the page will go back to whatever the page
defaults are. 

Moving to Browser because this isn't specific to Firebird.

Suggest resolve as INVALID.
Assignee: blake → general
Component: General → Browser-General
Product: Firebird → Browser
QA Contact: asa → general
Version: unspecified → Trunk
Dup, actually.

*** This bug has been marked as a duplicate of 46845 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.