Closed Bug 219216 Opened 16 years ago Closed 16 years ago

Problem with @->&#64; filter/munge and <input>

Categories

(Bugzilla :: Bugzilla-General, defect, major)

2.17.4
defect
Not set
major

Tracking

()

RESOLVED FIXED
Bugzilla 2.18

People

(Reporter: burnus, Assigned: justdave)

References

Details

Attachments

(1 file, 1 obsolete file)

Bug 120030 introduced the change that @ gets &#64;.
At least in the "Assigned to" text field this gets inserted using &#64; (shown
like this in the input field).
In which browsers?
Hmm, testcase works in Mozilla, MSIE, and Safari on OS X...

perhaps it's getting escaped twice?
OK, you forgot to say what page this was happening on, but I found it.  It's on
enter_bug and it's because the names are being fed via javascript, and they have
"FILTER html" on them instead of "FILTER js".

Patch coming shortly.
Status: NEW → ASSIGNED
OS: Linux → All
Hardware: PC → All
Target Milestone: --- → Bugzilla 2.18
Attached patch Patch (obsolete) — Splinter Review
This fixes the immediate problem, but it reintroduces the spam situation (if
they're scanning the page source, which we know they do because of the volume
of spam the bugzilla.org mailserver rejects for 1.0@bugzilla.org :)  we should
probably split the mail addresses in the javascript and patch them together at
runtime when putting them into the box.
Comment on attachment 131464 [details] [diff] [review]
Patch

filter js needs to convert @ to \x40
Attachment #131464 - Flags: review+
Oooh....

    components[0] = "Database backend";
    default_owners[0] = "justdave\x40syndicomm.com";
    components[1] = "Miscellaneous";
    default_owners[1] = "justdave\x40syndicomm.com";

Yep, it works.   It feeds "justdave@syndicomm.com" into the edit box.
Attached patch Patch v2Splinter Review
Add a @ -> \x40 to the js filter.
Attachment #131464 - Attachment is obsolete: true
Attachment #131468 - Flags: review+
Checking in Bugzilla/Template.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/Template.pm,v  <--  Template.pm
new revision: 1.12; previous revision: 1.11
done
Checking in template/en/default/bug/create/create.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/bug/create/create.html.tmpl,v
 <--  create.html.tmpl
new revision: 1.21; previous revision: 1.20
done
Status: ASSIGNED → RESOLVED
Closed: 16 years ago
Flags: approval+
Resolution: --- → FIXED
*** Bug 218585 has been marked as a duplicate of this bug. ***
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.