Closed Bug 219225 Opened 19 years ago Closed 7 years ago

underline position is too low for non-CJK langgroups

Categories

(Core Graveyard :: GFX: Win32, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: jshin1987, Assigned: jshin1987, NeedInfo)

References

Details

(Keywords: intl)

Attachments

(1 file)

In bug 156943 and bug 76097, the underline position was lowered toward the
descent because for CJK, the underline crossing the lower part of a glyph hurts
the readabilty rather severely. However, in Western typography (for this bug,
let's forget about Indic cases where the baseline is around a third from the top
of bbox [1]), the underline usually crosses the lower stem of 'p' and 'g'
instead of brely touching the bottommost part. Therefore, I'm proposing that we
get back to what we used to have for *non-CJK* lang groups. And, I'll do the
same in bug 218032. 

[1] That's, I read, why 'pan-unicode' fonts need to have multiple
script-specific baselines, but I have little idea how they can actually be used
in rendering/layout.
Attached patch a patchSplinter Review
Even with this patch, something is not quite right. Still MS IE's rendering of
underlined text(European text) looks better than that of Mozilla.
it might be a 1-off(or even 0.5-off) difference.
Status: NEW → ASSIGNED
Summary: underline position is too lower for non-CJK langgroups → underline position is too low for non-CJK langgroups
win98 2004022608
at this page underline is so low it falls on the next line
http://www.italieni.it/
*** Bug 226590 has been marked as a duplicate of this bug. ***
Product: Core → Core Graveyard
This bug has been buried in the graveyard and has not been updated in over 5 years. It is probably safe to assume that it will never be fixed, so resolving as WONTFIX.

[Mass-change filter: graveyard-wontfix-2014-09-24]
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
Assuming this bug is still present, it should be moved to Core:Text.   But is it still present?
Flags: needinfo?(gphemsley)
Flags: needinfo?(gphemsley) → needinfo?(jshin1987)
You need to log in before you can comment on or make changes to this bug.