downloading puts file in temp directory first, then moves to final destination

VERIFIED DUPLICATE of bug 69938

Status

SeaMonkey
Download & File Handling
VERIFIED DUPLICATE of bug 69938
15 years ago
13 years ago

People

(Reporter: Holger Jakobs, Assigned: Blake Ross)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; de-AT; rv:1.4) Gecko/20030624

When downloading a file, it is first put in the Windows temp dir under a funny
name. After the download is finished, the file is copied to the final
destination. problems arise if the file is big: the disk with the temp dir might
have not enough free space; copying takes a long time if temp dir and final dir
are not in the same file system.

Reproducible: Always

Steps to Reproduce:
1. download a big file (from a local server)
2. watch how the file is copied again in your local machine from one place to
another




Expected Results:  
If I choose a destination directory and file name for a download, Mozilla should
adhere to it and NOT make a decision to put the file (temporarily) elsewhere. In
the Linux version it works fine, in the Windows version it behaves as described
and critisized.

Comment 1

15 years ago
This looks like a dup. of bug 69938.  Reporter, if you agree can you mark as
such (I don't have the correct privs.)

Comment 2

15 years ago
*** This bug has been marked as a duplicate of 69938 ***

*** This bug has been marked as a duplicate of 69938 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.