Live Connect disabled on Mac OS X Javascript cannot communicate with Java

RESOLVED DUPLICATE of bug 97613

Status

--
major
RESOLVED DUPLICATE of bug 97613
15 years ago
8 years ago

People

(Reporter: benmozilla, Assigned: joshua.xia)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)
Build Identifier: 1.4 and Camimo from 14 Sept 2003 front page downloads

I'm sorry this isn't as complete as I'd like, but I only have intermittent 
access to an OS X machine.

This is using OS X with the newest Apple 1.3/1.4 Java.  LiveConnect doesn't 
work at all in any way shape or form.

This disables the webapplication we were developing.

This did work on OS X in Mozilla (and NS) in the spring.  That version of 
Mozilla still _didn't_ work now, so I believe it's something Apple changed to 
the system-wide Java implimentation.


Reproducible: Always

Steps to Reproduce:
1.Using OS X, open any page that has Javascript communicate with Java 
(LiveConnect)
2.Try to have Javascript communicate with Java
3. Fail

Actual Results:  
No communication; nothing.



Expected Results:  
Java should be able to get Javascript messages

Comment 1

15 years ago
---> OJI
Assignee: rogerl → joshua.xia
Component: Live Connect → OJI
QA Contact: pschwartau → general
So... why is this a Mozilla bug instead of an Apple one if they broke things?
*** Bug 219286 has been marked as a duplicate of this bug. ***

Comment 4

15 years ago
Apple didn't break things. They
a) took away the java embedding APIs in Java 1.4 that our MRJ plugin uses, so our
   plugin was not upgradable to Java 1.4
b) didn't fulfill their promises to implement LiveConnect in their java plugin.

Bug 97613 covers this.

*** This bug has been marked as a duplicate of 97613 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.