Focus/Context/Window Title issues when reading email

RESOLVED DUPLICATE of bug 172392

Status

SeaMonkey
MailNews: Message Display
--
minor
RESOLVED DUPLICATE of bug 172392
15 years ago
13 years ago

People

(Reporter: Andrew, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030827
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030827

I use the "Open Messages in a New Window" option, and have Mail/News set up to a
2 pane system, with my servers/folders on the left and the contents of the
current folder on the right.

This bug may need a better summary, but I'm at a loss as to what to call it.  Sorry.

Upon deleting a message, the focus in the index of the folder gets lost and
reset.  Upon closing the message window, in a large mailbox, one has to find the
message if they wish to do something with it.  Even though a new message or the
next unread message is displayed in the new window, the Mail/News application
gets it's pointer in the folder reset

Reproducible: Always

Steps to Reproduce:
1. Set your preference to open new messages in a separate window
2. Open a folder with a few messages in it
3. Select a message somewhere in the middle of the folder with one click, double
click it to open it in a new window
4. Delete this message.  The next message appears.
5. Close this window.
6. Focus goes to the Mail/News window, or select it.
7. The title bar doesn't show what message you were on, nor does focus indicate
where you were
8. Find that message, or open another message
9. Simply close the window
10. The title bar contains the subject of the message you were on, and focus
indicates where you were

Actual Results:  
Mail/News can display a message, but not have current context of it in the main
Mail/News window

Expected Results:  
I'd expect the pointer/focus in the folder window to move along with the current
message.  Upon closing the secondary window, I'd expect some visual clue as to
where I was in the folder.  It only gets lost when one deletes a message
(haven't checked what happens when one moves a message from the new message window).

Windows 2000, Mozilla 1.5b, Classic theme

I realize this may be a bit complex, but I'll answer questions as they come up.
 I'm going to classify this as a Minor bug, but it really drives me crazy with
the way I typically read email.

Comment 1

14 years ago
Note that the "problem" is not loss of focus, but loss of selection.  See also 
bug 183486.

The reason I quote "problem" is that the reporter's expected navigation model 
causes its own problem: which message should the message pane select when 
next/delete operations are taking place in more than one standalone message 
window?

*** This bug has been marked as a duplicate of 172392 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.