Page setup - scaling percentage does not persist between mozilla sessions

RESOLVED DUPLICATE of bug 147384

Status

()

RESOLVED DUPLICATE of bug 147384
15 years ago
15 years ago

People

(Reporter: arielt, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030827
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030827

When I uncheck the ``Shrink to fit page width'' option (from File - Page Setup),
the option holds merely for the current session of mozilla.
    I define this as a bug, because of its equivalent: page orientation
(portrait or landscape) which persists between sessions.  Actually, I think
both options should have a ``make default'' button, where the user could say
whether he/she wants the selected option to remain for later sessions as well.

    Just to explain the background why I need this option:  I use font size 20
for viewing web pages, because the default (12) appears tiny on my laptop.
However, once it gets to print, a font of size 20 is huge.  I therefore need
a different size for display than for printing.  Now, I tried 2 options:
1.  Use font 12, and zoom the text.
2.  Use font 20, and scale printing by 50%.
The problem is that both these options disappear when I quit mozilla, and
I have to set them each time.  Maybe a more general option is necessary
in the preferences to solve this problem.

Reproducible: Always

Steps to Reproduce:
1.  Unmark ``Shrink to fit page width'' in Page Setup.
2.  Quit mozilla.
3.  Run mozilla again.
4.  Enter ``Page Setup''.


Actual Results:  
In the second run, ``Shrink to fit page width'' is checked again.

Expected Results:  
``Shrink to fit page width'' remains unchecked.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 147384 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.