Closed Bug 219502 Opened 17 years ago Closed 15 years ago

Warning about mixed encrypted/not-encrypted content is not displayed

Categories

(Core Graveyard :: Security: UI, defect, major)

Other Branch
x86
Windows XP
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 135007

People

(Reporter: a.schild, Assigned: dveditz)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [sg:fix])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4; MultiZilla v1.5.0.1) Gecko/20030812
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4; MultiZilla v1.5.0.1) Gecko/20030812

In the page mentioned above, the image URL points to a http: image, not a https:
link.
When in the preferences the "Viewing a page with a encrypted/unencrypted mix"
is checked, but not such warning is displayed.

Reproducible: Always

Steps to Reproduce:
1. Turn on the  "Viewing a page with a encrypted/unencrypted mix" checkbox in
the SSL warnings preferences.
2. Go to the URL mentioned


Actual Results:  
No warning about the image in non-https mode is displayed.

Expected Results:  
A warning dialog who tells me that some elements on this page are insecure.

Looking at the page infos, under Media, we see that the image
is realy served from a http:// link.
The same problem still occurs in the build 20030915
Mass reassign ssaux bugs to nobody
Assignee: ssaux → nobody
Product: PSM → Core
Assignee: nobody → dveditz
Blocks: lockicon
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-aviary1.1+
Whiteboard: [sg:fix]

*** This bug has been marked as a duplicate of 135007 ***
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Flags: blocking-aviary1.5+
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.